Lockup with Patchbox OS

#1

I have what I hope is not too ambitious of a goal for my little Raspberry Pi 3 model B 1.2.

I was using Raspbian Buster, SooperLooper, QJackctl, Hydrogen, non mixer, non session manager. Was pretty stable but lots of click and glitch in the audio, so not usable.

Then I switched to Patchbox. A few false starts then it seemed OK. Didn’t hear the crispies like before.

I was running Hydrogen as Jack master to Sooper Looper and got a couple tracks going here. Sounded OK considering I was just goofing around. Then it locked up hard.

If there’s some way to debug this, please let me know.

I just got a 3 amp power supply to use with this Pi. It is in a case with a 7" LCD touchscreen. I have a Macmillen Softstep MIDI foot pedal, Behringer UMC404 USB audio interface (with its own power supply), USB keyboard and wireless mouse. With an older power supply I was getting undervoltage warnings but no longer.

0 Likes

#2

Is there anything useful in dmesg logs when the issue occurs? Also you can access the logs of previous boots. But first, storing them might have to be enabled.

0 Likes

#3

I don’t know how to interpret this log. There’s some problem with Pisound, which I am not intending to use, and I don’t need bluetooth either.

I can’t upload the full log. Here’s a part at the end that keep repeating.

Dec 06 04:47:37 patchbox pisound-ctl[1733]: [1733] main: Pisound Control Server 1.03 starting...
Dec 06 04:47:37 patchbox systemd[1]: pisound-ctl.service: Main process exited, code=exited, status=234/MAKE_STARTER
Dec 06 04:47:37 patchbox systemd[1]: pisound-ctl.service: Unit entered failed state.
Dec 06 04:47:37 patchbox systemd[1]: pisound-ctl.service: Failed with result 'exit-code'.
Dec 06 04:47:42 patchbox systemd[1]: pisound-ctl.service: Service hold-off time over, scheduling restart.
Dec 06 04:47:42 patchbox systemd[1]: Stopped Bluetooth service for Pisound companion app..
Dec 06 04:47:42 patchbox systemd[1]: Started Bluetooth service for Pisound companion app..
Dec 06 04:47:42 patchbox pisound-ctl[1735]: Reading Pisound version failed, did the kernel module load successfully?
Dec 06 04:47:42 patchbox pisound-ctl[1735]: [1735] main: Pisound Control Server 1.03 starting...
Dec 06 04:47:42 patchbox systemd[1]: pisound-ctl.service: Main process exited, code=exited, status=234/MAKE_STARTER
Dec 06 04:47:42 patchbox systemd[1]: pisound-ctl.service: Unit entered failed state.
Dec 06 04:47:42 patchbox systemd[1]: pisound-ctl.service: Failed with result 'exit-code'.
Dec 06 04:47:47 patchbox systemd[1]: pisound-ctl.service: Service hold-off time over, scheduling restart.
Dec 06 04:47:47 patchbox systemd[1]: Stopped Bluetooth service for Pisound companion app..
Dec 06 04:47:47 patchbox systemd[1]: Started Bluetooth service for Pisound companion app..
Dec 06 04:47:47 patchbox pisound-ctl[1737]: Reading Pisound version failed, did the kernel module load successfully?
Dec 06 04:47:47 patchbox pisound-ctl[1737]: [1737] main: Pisound Control Server 1.03 starting...
Dec 06 04:47:47 patchbox systemd[1]: pisound-ctl.service: Main process exited, code=exited, status=234/MAKE_STARTER
Dec 06 04:47:47 patchbox systemd[1]: pisound-ctl.service: Unit entered failed state.
Dec 06 04:47:47 patchbox systemd[1]: pisound-ctl.service: Failed with result 'exit-code'.
0 Likes

#4

You can stop the service from starting by running:

sudo systemctl stop pisound-ctl
sudo systemctl disable pisound-ctl
0 Likes

#5

Okay, I’ve disabled and stopped pisound-ctl and bluetoothd and rebooted.

Started qjackctl and Hydrogen. Within 3 minutes of working on a simple pattern in Hydrogen it locked up again.

I’m not seeing undervoltage warnings. Yesterday I saw some high temp warning and the widget shows 65 to 68 temps. I put a heat sink on the CPU and other chip which brought those down maybe 5 degrees.

Update - I ran the config program (when I first ran it, the USB sound card was not installed) and selected the USB sound card and perhaps more importantly, turned off the wifi hotspot mode. I hope it is not a fluke, but I’m now running qjackctl, hydrogen, sooperlooper, non mixer and non session manager over VNC and it has not locked up even after ten minutes.

Was it the wifi hotspot mode? Maybe. I’ll keep this going. It’s very desirable for me to get this setup working on a Pi. If I can’t, I think I will just get a cheap laptop and run Ubuntu Studio on it.

0 Likes

#6

It’s much more stable now but I am getting glitches in recorded audio pretty much like when I was just using non real time Raspbian. If I can attach a small WAV file, I will. Well I guess I can’t because I’m still a new user. Blah blah blah. Does it count words or posts? Blah.

0 Likes