Jack failure after upgrade -- Raspi 4

I was using 2020-11-23 image on my Raspi 4 for a long time without any issue.
However, after I “sudo apt update && upgrade”, jack cannot start correctly. Is there any compatibility issue?

I installed the RT kernel via Patchbox which solved the jack issue.
However, I lost the function of all 4 USB ports.
FYI: I’m using a 4G ram version of Raspi-4.

I also have this problem, I just updated and after restarting I lost communication with my 4 USB ports.
I also noticed an increase in CPU load and glitches even increasing the latency in Jack’s configuration.
I will try to search for something on other forums related to tou, but first I will try to downgrade.
Wish me luck

It seems to be the kernel issue, and here’s a temporary solution:

1 Like

It is definitely an issue with the kernel, I just installed the regular version via ‘patchbox-config’ and everything worked perfectly, except for the jack, still trying to understand, besides I’m having overheating problems, I have to figure out how to solve this.
Thanks for the help, my USB is working again, I managed to reduce the glitches by increasing the latency in the jack settings, but it is still not the perfect solution.
It will be necessary to compile the kernel from scratch, I will try this later and come back here.

The realtime kernel branch was not updated for 8GB Raspberry Pi. If anyone gets it working with the 8GB version, please let us know. :slight_smile:

Just an update on the subject: I reinstalled the last stable image of Patchbox OS and everything went back to working as expected again. I believe the problem is not with the kernel itself. There is no recommended kernel update, but it does have Jack (Blokas build) and driver firmware. I didn’t perform the updates to test Jack’s configuration with low latency. I have an RPi 4 with 4gb of ram.

Hey @Giedrius do you need any more precise information to help in this matter?

1 Like

Ok, I thought you might try applying the RT patch on some up to date kernel source version. :slight_smile:

Yeah, after several trial and error, I went back to the original 2020-11-23 image, which seems to be the only stable one for Raspi-4 4GB.

@rafaeletc: For the RT kernel, other than the USB port problem, I also got the same problem when using Pisound as the audio interface.

Interesting thing is that CPU load is actually not high shown in the Task Manager. However, this would not happen when using the onboard bcm2835.

Interesting, everything is ok here. Did you update via APT?
I’m using the following Jack configuration: samplerate 48000, buffersize 128,
period 2 (with PiSound as driver).
I just updated Patchbox using the ‘patchbox-config’ command and PiSound using
the ‘pisound-config’ command

I’m running the effects smoothly here.