Install.sh kills my wifi

I’m using Raspberry Pi OS, just runs curl https://blokas.io/pisound/install.sh | sh

In progress, failed cloning pisound.git at twice.

After this, my wifi doesn’t work.

Try running this command: systemctl disable --now patchbox-wifi, and try again.

Have the same problem.
The WiFi setting is changed after symlink…

How can I adjust my WiFi back?
The command “systemctl disable --now patchbox-wifi” give me the error “Unit file patchbox-wifi.service” does not exist.
I installed a debian-bullseye from cycling74 site.

More detailed report here from the terminal:
Created symlink /etc/systemd/system/multi-user.target.wants/wifi-hotspot-autodisable.service → /lib/systemd/system/wifi-hotspot-autodisable.service.
Created symlink /etc/systemd/system/multi-user.target.wants/wifi-hotspot.service → /lib/systemd/system/wifi-hotspot.service.

13:52:13 Timeout, server 192.168.178.41 not responding
13:52:13 Disconnected from server
13:52:13 Connection failed, retry after 3 seconds…
13:52:16 Connecting to 192.168.178.41 port 22

Fixed this in patchbox-wifi package, running install.sh while connected to the Pi via wireless should now work fine.

@ Giedrius
Thanks, but how can I change the WiFi-Hotspot to a WiFi-client in my home-WiFi via terminal or GUI? Otherwise I cannot do a new “install.sh” or I am wrong?

Try holding the button down for 3 seconds, it should disable the hotspot mode, or set up the WiFi on your PC/laptop by creating the wpa_supplicant.conf on the SD card, same folder that contains the ‘config.txt’. Or connect your Pi by a network cable, or use keyboard & mouse, or just flash the SD again. :slight_smile:

@Giedrius Thanks, I did a new flash SD, now it works.

1 Like