How to install/run Qjackctl?

#1

Hi all,

I’m trying to run qjackctl on a fresh Patchbox OS install; I installed it by using

sudo apt-get install qjackctl

When I run it and try to start the server, I get the error messages that I’ve copied below. Should I alter the existing jack installation in some way?

Thanks in advance.

01:01:26.555 Statistics reset.

01:01:26.620 ALSA connection change.

Cannot read socket fd = 14 err = Success

CheckRes error

JackSocketClientChannel read fail

Cannot open qjackctl client

JackShmReadWritePtr1::~JackShmReadWritePtr1 - Init not done for -1, skipping unlock

JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock

JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock

01:01:31.709 ALSA connection graph change.

01:01:39.670 JACK is starting...

01:01:39.672 /usr/bin/jackd -dalsa -dhw:0 -r48000 -p1024 -n2

Cannot read socket fd = 14 err = Success

CheckRes error

JackSocketClientChannel read fail

Cannot open qjackctl client

JackShmReadWritePtr1::~JackShmReadWritePtr1 - Init not done for -1, skipping unlock

JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock

JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock

01:01:39.735 JACK was started with PID=2001.

jackdmp 1.9.12

Copyright 2001-2005 Paul Davis and others.

Copyright 2004-2016 Grame.

Copyright 2016-2017 Filipe Coelho.

jackdmp comes with ABSOLUTELY NO WARRANTY

This is free software, and you are welcome to redistribute it

under certain conditions; see the file COPYING for details

JACK server starting in realtime mode with priority 10

self-connect-mode is "Don't restrict self connect requests"

Cannot allocate synchro

Cannot allocate internal client for driver

Cannot initialize driver

JackServer::Open failed with -1

Failed to open server

01:01:40.522 JACK was stopped

01:01:46.978 Could not connect to JACK server as client. - Overall operation failed. - Server communication error. Please check the messages window for more info.

Cannot read socket fd = 14 err = Success

CheckRes error

JackSocketClientChannel read fail

Cannot open qjackctl client

JackShmReadWritePtr1::~JackShmReadWritePtr1 - Init not done for -1, skipping unlock

JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock

JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
0 Likes

#2

You shouldn’t need to start a new jack server - Patchbox OS is preconfigured to have one shared jack service for all the audio software. You can use the included patchage software with to do the jack routings.

If you do want to use qjackctl anyway, then you should first stop the running jack service: sudo systemctl stop jack.

0 Likes

#3

Thanks Giedrius - if it’s not too much trouble, could you please check that that actually works? I remember having tried to stop the jack service first earlier this week, and qjackctl didn’t work. I will try myself also later tonight.

The reason I’d like to use qjackctl is because I’ve already built a system that uses two USB audio devices simultaneously with zita-ajbridge, and autoconnects them to PD. I’d like to use the realtime features of Patchbox OS - perhaps I can use patchage for the same goal…

0 Likes

#4

Just tested it - it does work like you said. What I’d like to do though is start qjackctl automatically at boot, without jack already running. I thought this could be achieved by

sudo systemctl disable jack

… but when I do that, reboot and then start qjackctl, the jack server is already running. Is there another service that starts jack at startup, that I can perhaps modify or disable?

0 Likes

#5

Try disabling these services: pisound-ctl , mec , orac , patchbox-init, as they may be starting or depend on jack.service.

0 Likes