How to connect to pisound/raspberry pi after modep install

#1

Hi, very much a beginner with the whole raspberry pi and linux thing,
but I’ve got a Raspberry Pi 3 + pisound with the latest MODEP-image installed
([Beta] MODEP 2018-01-22)

I’ve got MODEP working OK, testing out some synths with filters and effects, using a USB-MIDI keyboard.
There seem to be some glitches (I’m using the FludSynthLead + LowPass-filter + Phaser and a delay; the CPU is approx 33% and hardly any x-runs (maybe 10-20 over a period of 15-20 minutes).

But for the life of me I cannot figure out how to connect to the Raspberry from my laptop, for example to change the JACK-buffer (as discussed elsewhere). I’ve been able to connect to the Raspberry board with a clean install of Raspbian (using Xming-server, an ethernet cable and Putty), but once MODEP is installed I cannot login to the Raspbian.

The pedalboard view, using Pisound’s hotspot is working fine though in my browser, so I am able to connect to the unit, only not able to change any settings on the unit.

So, how do I login to my Raspberry Pi, with MODEP installed?

cheers,

0 Likes

[Beta] MODEP 2018-01-22
#2

Hi, sorry for the stupid question(s),

but I’ve gotten the MODEP 2018-01-22 to work on my Raspberry Pi 3 w Pisound HAT,
but writing the image directly to an SD card. I’ve tried previous versions with an electric guitar and there were some glitches, but this latest version I’ve only tried as a synth generator (FluidLeadSynth) + filter + delay, controlled by an AKAI MPK-mini USB-controller. And there are quite a few glitches when I play.

I’d like to try to change the JACK-settings (using my laptop running Windows 8.1) but I have no idea how to connect to the Raspberry to run any of the commands (I was able to run a terminal window with a fresh Raspbian setup but once MODEP was installed the Raspberry went black).

So, for example; If my laptop is connected to the Pisound WiFi hotspot (and 172.24.1.1. works in the browser to view and edit the pedalboard) where do I type “ssh modep@172.24.1.1” ? In my browser (that’s not working)? where else? I’ve tried Putty and there’s no connection, I’ve tried saving a file called SSH on the SD-card an that doesn’t change anything, and several other methods but nothing seems to work (including installing the Bonjour Print Server to be able to use mDNS).

It feels like I’m missing some obvious piece of the puzzle, but I’ve no idea where to start looking for it.

cheers,

0 Likes

#3

Hi, I have moved your reply on the beta image thread here, as they are both related and best to be on its own topic. :slight_smile:

For connecting to ssh on Windows, see here: https://www.raspberrypi.org/documentation/remote-access/ssh/windows.md

Once you have connected to Pisound’s WiFi hotspot, use modep for user, 172.24.1.1 for the IP and blokaslabs for password.

0 Likes

#4

Thanks @Giedrius, I will have to try this once again when I get back; I have been able to connect to the WiFi hotspot, and I’ve been able to see the Raspberry using IP Scanner but using the 172.24.1.1 address in Putty has so far not worked for me. I was obviously on the right track but something else is missing,

cheers,

0 Likes