Glitches and Pop with Pisound : how to optimize audio

Hi Gierdrius,
I was running my PD patch really fine (I guess it has always been with 48khz 64 buffer, like now, but I’m not sure unless something changed for some reason).

I don’t use the graphical interface and just loading the patch at startup from the console.

Since I made some slight updates (added bitcrusher, some logarythmic values for CC controllers and some tap tempo via MIDI) , I occur some random pops and glitches (but rare) when I play with my patch.
It’s not ultra annoying, because it’s rare and really short, but I haven’t had such problems before.

What are your advices for optimizing sound, if possible staying with the lowest buffer because I perform live ? (playing my pd patch with a usb keyboard MPK mini)

Does WIFI on or bluetooth on can influence audio performances for example ? crappy USB cables for the controller ?

Thank you !

Yes, the more things you can turn off, the less the OS is busy with randomly occurring unrelated tasks.

Still, the best way to add stability is to slightly increase the buffer size until it’s flawless, try playing around with the buffer sizes and see if you get more stability and if it’s still quick enough.