Getting TouchOSC to work


#1

Hi all. I can’t seem to get TouchOSC to work… here’s some info:

Raspberry Pi 3B+ with stock 2018-09-11-MODEP image and Pisound hat;
iPad connected to MODEP WiFi network, connecting to 172.24.1.1 and modep.local in mobile Safari works;
TouchOSC v1.9.10 (most recent) with settings:

  • Host: 172.24.1.1
  • Port (outgoing): 12101
  • Port (incoming): 9000 - not that it’s very relevant I guess
  • Layout: Simple - which is a stock layout that has MIDI CC’s mapped to every control

In MODEP interface (controlled by laptop), in MIDI Ports: tick box for alsa_pcm:touchosc/midi_playback1(in), click Save

Drag an effect onto the screen, click its settings icon, parameters appear;
Click on the settings for a knob, from dropdown menu select MIDI Learn…
Click Save as instructed

Move fader on iPad - no effect.
Change TouchOSC layout to Keys and connect MIDI input to MDA ePiano - no effect.
Activate and use hardware MIDI Pisound input and connect that - it works.

For testing I have an iPhone with TouchOSC;
when I change the URL in TouchOSC for iPad to the iPhone’s, there is communication.

Please help :slight_smile: thanks!


#4

Just tried it with a 3B… still no OSC input


#5

Still not getting any input via TouchOSC… how can I troubleshoot this? I have already installed a desktop environment on this MODEP card, perhaps that helps.


#6

Alright I’ve found that if I send OSC data to 172.24.1.1 on a different port than 12101, and I listen for it in Purr Data with a netreceive object, I do see it.

Sending data to 12101 and trying to map something to a controller with MIDI Learn still does nothing.


#7

Hey, I tried using MyOSC app on Android with MODEP, and it seems to work correctly with stock 2018-09-11 MODEP image… What is the output of:

sudo systemctl status

?


#8

And for that it’s worth: I’ve opened up qjackctl to take a look at the MIDI routing; touchosc is connected to RtMidi both ways. When I also connect the MIDI output of Purr Data to touchosc and send some CC messages, it (MIDI Learn) works.


#9

Hi Giedrius! I’m now coming to you ‘live’ from my MODEP desktop, so I can copy-paste stuff if needed. The output of

sudo systemctl status

is quite large… and starts with State: degraded

anything specific I should notice?


#10

Here’s the first couple of lines:

modep
State: degraded
Jobs: 0 queued
Failed: 1 units
Since: Thu 1970-01-01 01:00:02 CET; 49 years 0 months ago
CGroup: /
├─user.slice
│ └─user-1000.slice
│ ├─user@1000.service
│ │ ├─gvfs-gphoto2-volume-monitor.service
│ │ │ └─981 /usr/lib/gvfs/gvfs-gphoto2-volume-monitor
│ │ ├─dbus.service
│ │ │ ├─831 /usr/bin/dbus-daemon --session --address=systemd: --nof
│ │ │ └─933 /usr/lib/dconf/dconf-service
│ │ ├─gvfs-udisks2-volume-monitor.service
│ │ │ └─941 /usr/lib/gvfs/gvfs-udisks2-volume-monitor
│ │ ├─gvfs-mtp-volume-monitor.service
│ │ │ └─985 /usr/lib/gvfs/gvfs-mtp-volume-monitor
│ │ ├─gvfs-goa-volume-monitor.service
│ │ │ └─977 /usr/lib/gvfs/gvfs-goa-volume-monitor
│ │ ├─gvfs-afc-volume-monitor.service
│ │ │ └─989 /usr/lib/gvfs/gvfs-afc-volume-monitor
│ │ ├─init.scope
lines 1-23…skipping…
● modep
State: degraded
Jobs: 0 queued
Failed: 1 units
Since: Thu 1970-01-01 01:00:02 CET; 49 years 0 months ago
CGroup: /


#11

Please run sudo systemctl now, without ‘status’ argument, then you should be able to identify which service has failed in the list.


#12

That seems to be:

resize2fs_once.service loaded failed failed resize2fs_once.service

which is perhaps the resizing of the partition from the start of the tutorial on how to install a graphical Raspbian desktop… before that OSC input didn’t work either


#13

Looking at https://itunes.apple.com/us/app/touchosc/id288120394?mt=8, there’s: ‘- Added option to send all OSC messages as bundles with timestamps’

This may be breaking compatibility with touchosc2midi, could you check if you can find this option in the app’s settings and try to disable it if it’s on? I can’t find anything about this option in the documentation of the app.


#14

The option is there but it isn’t and hasn’t been activated. I’ve not been able to find MyOSC for download anywhere; OSC from Lemur doesn’t work either. I’ll try sending OSC from Purr Data on another Rpi next.

Any other suggestions for troubleshooting?


#15

Made a OSC patch in Purr Data on a second Rpi that sends a parameter, tested it by sending it to TouchOSC, works.

Then connecting it to the MODEP wifi point, testing the connection with ping - that works. MIDI Learn on a parameter however again doesn’t.


#16

Is there any requirement for how the OSC messages have to be formatted in order for them to work in the context of MIDI Learn in MODEP?


#17

I have just tried out TouchOSC on Android, it works with MODEP ok, see the attached screenshot of how I have configured it. Also all the checkboxes in options menu are unticked.


#18

Ahhhh… that was it, it works now, thank you very much.

And I apologize - I thought the idea was to establish a normal OSC connection, partly because I read that the port number 12101 needed to be specified. Perhaps the documentation could be a little more specific in that regard.


#19

We’ll add a quick note in the documentation on how to set up TouchOSC client.