Freshly installed Patchbox + MODEP sound quality issue

Hello there, I’wanted to try the new MODEP so I installed Patchbox with MODEP module but I am getting really bad sound quality on exactly the same hardware I was using with the old MODEP version on Raspbian. The only difference is the SD Card, I used a new one in order to keep the old (working) system alive. I guess this SD is not top quality and speed, but I thought to myself that this could affect just the responsiveness of the system, not the sound quality… Maybe I’m wrong.

The sound I’m getting is full of scratch and glitches, even with an empty pedalboard. No XRUN and CPU less than 10%. As I start to load plugins, the sound get worse, tend to be digitally distorted and sometimes randomly it turns to noise for no apparent reason. I can provide you with a sound sample if you wish.

I tried to adjust every possible jack settings combination, I even tried a different sound card a different USB cables, but nothing seems to fix the problem.

My Hardware:
RPi 3B+
Original RPi power supply 2.5A
Audio cards: NI RigKontrol 2 / Behringer XR18 (digital mixer)
SD: unknown brand… :slight_smile:

Thanks in advance for your help.

Make sure the settings in alsamixer are alright. Set the input gain level to minimum possible level.

Not really sure what could be so different from the other SD card you have. The speed itself should only impact system responsiveness while it is loading stuff to RAM, afterwards, it should be OK.

Hey Giedrius, thank you for your super-quick response! I’m amazed of the great job you guys do, and your care and support.

I think alsamixer is ok, in fact it doesn’t sound like a signal clipping or something like that, the clicks and the distorsion I hear remind me of a clock problem or frame missing if you know what I mean. Anyway, I’ll make some more tests and see if I can come up with some clue.

I’ll also try to record a video or a sound sample to give you a better idea.

So if you simply swap out the new SD card for the one containing old installation, there’s no noise issues? In that case I’d suspect something with audio drivers. You may give ‘stock’ kernel a try, simply run:

sudo apt install raspberrypi-linux

and reboot.

To install our build of the real time kernel back, run:

sudo apt install raspberrypi-linux-rt

and reboot.

It complains about not finding the raspberrypi-linux package…

Probably you meant raspberrypi-kernel and raspberrypi-kernel-rt… Is that correct? :wink:

Yes, correct :slight_smile:

I tried the stock kernel and at first I thought it worked better, but at some point the sound the sound was screwed up again. I upload a little sample in FLAC format.

Jack Settings: 44100 - 128 - 2
Audio Card: RigKontrol2

Modep.zip (686.7 KB)

“Help me Giedrius you’re my only hope” :rofl:

128 and 2 are quite low values for USB sound cards, you should try slightly larger and safer values like 256 - 2 or 128 - 3.

There’s also some information on the internet on how to better configure USB audio interfaces for Raspberry Pi, you could try going through them and see if it helps. Maybe you had done some such configuration on the older installation?

Thank you Giedrius, I actually tried every possible combination, including 1024 - 6 (even it’s not suitable for live performing, but just to see what I got)
Sometimes it works sometimes it doesn’t, it’s really unpredictable.

I’ll keep trying to figure out what’s going on.

1 Like