FAQs - Pisound Docs

Dedicated topic for FAQs - Pisound Docs page.

This is a companion discussion topic for the original entry at https://blokas.io/pisound/docs/FAQs/

Can I configure the DHCP of pisound to always assign the same address to the tablet/phone that connects? This is in order to send messages back from my app to the tablet without entering the tablet’s ip address each time

Yes, add a line like this to /etc/dnsmasq.d/wifi-hotspot.conf and restart the hotspot:

dhcp-host=01:23:45:67:89:ab,172.24.1.50

01:23:45:67:89:ab should be replaced with the MAC address of your tablet/phone.

Use cat /var/lib/misc/dnsmasq.leases to see the connected clients with their MAC addresses. The IP must be in the range [172.24.1.50; 172.24.1.150], as defined by dhcp-range in dnsmasq.conf.

See https://www.linux.com/learn/intro-to-linux/2018/2/dns-and-dhcp-dnsmasq (Set Static Addresses from DHCP section) for more info.

1 Like

Hi Giedrius,

I have set up the wifi hotspot, but, when I try to connect to it on my phone, I just get a spinning wheel. Can you help me to trouble shoot this?

thanks!

Hi. I’m having trouble controlling orac with midi via touchosc. The client from my iPad is sending midi to the piSound (I see the light flashing) and I can control orac with a usb midi controller, but sending midi from touchosc doesn’t get received by orac. Is there any way to make this work?

Thank you!

By the way, I made a live change that got it working (running “aconnect 132:0 133:0” see below). Is there a way to change the /usr/local/patchbox-modules/orac/amidiauto.conf to establish this without having to do it manually? I don’t fully understand how that file works. Thank you for help you can provide!

**patch@patchbox** : **~ $** aconnect -l

client 0: 'System' [type=kernel]

0 'Timer '

1 'Announce '

Connecting To: 129:0, 128:0

client 14: 'Midi Through' [type=kernel]

0 'Midi Through Port-0'

Connecting To: 129:0[real:0]

Connected From: 129:0

client 20: 'pisound' [type=kernel,card=1]

0 'pisound MIDI PS-0WAVR0A'

Connecting To: 129:0[real:0], 133:0

Connected From: 129:0, 132:0, 133:1

client 24: 'Launchkey Mini MK3' [type=kernel,card=2]

0 'Launchkey Mini MK3 MIDI 1'

Connecting To: 129:0[real:0], 133:0

Connected From: 129:0, 132:0, 133:1

1 'Launchkey Mini MK3 MIDI 2'

Connecting To: 129:0[real:0]

Connected From: 129:0

client 130: 'pisound-ctl' [type=user,pid=579]

0 'pisound-ctl '

Connecting To: 129:0[real:0], 133:0

Connected From: 129:0, 132:0, 133:1

client 131: 'RtMidiIn Client' [type=user,pid=635]

0 'TouchOSC Bridge '

Connected From: 129:0, 132:0, 133:1

client 132: 'RtMidiOut Client' [type=user,pid=635]

0 'RtMidiIn Client:TouchOSC Bridge 131:0'

Connecting To: 20:0, 24:0, 130:0, 131:0, 129:0[real:0]

client 133: 'Pure Data' [type=user,pid=1107]

0 'Pure Data Midi-In 1'

Connected From: 20:0, 24:0, 130:0, 129:0

1 'Pure Data Midi-Out 1'

Connecting To: 20:0, 24:0, 130:0, 131:0, 129:0[real:0]

**patch@patchbox** : **~ $** sudo aconnect 132:0 133:0

Try including:

RtMidiIn Client:TouchOSC Bridge <-> Pure Data

or

RtMidiOut Client <-> Pure Data

line inside the allow list of /etc/amidiauto.conf. You must restart the service for changes to take place:

sudo systemctl restart amidiauto

The preferred line would be the first one, as it’s a more specific name. Let us know whether the first or second variation work. :slight_smile:

@Giedrius: Thank you so much for the help. In the end, I found it worked to make the changes to /usr/local/patchbox-modules/orac/amidiauto.conf instead of /etc/amidiauto.conf.

And I believe both lines were necessary to have the ability to do midi mapping to both the TouchOSC device as well as to my midi controller that was connected via USB.

I may have gotten confused in the permutations, but I can confirm that both settings together do at least work, even if they are redundant.

Thanks again for your help!

1 Like