external sound card recognized by alsa, but not pulseaudio

#1

hey there folks, I found this wicked sounding OS yesterday and have been trying to get it up and running with my PD patch that I previously had working on a normal version of raspbian(rpi3). As soon as I started it up and went through setup, it found my sound card immediately(zoom g3). I updated the pisound file that fixes the hotspot issue. Restarted, then it was no longer my default sound card. I had a look in aplay --list-devices, its there. Card 1. Had a look in pacmd list-cards, theres only the bcm2835.

At this point I checked to see if i had any sound coming through the headphone jack with an [osc] running in PD, there’s none. sudo systemctl status jack.service says it running:

Main PID: 379 (jackd)
CGroup: /system.slice/jack.service
└─379 /usr/bin/jackd -t 2000 -R -P 75 -d alsa -d hw:Series -r 48000 -

Jun 10 12:59:01 patchbox jackdrc[379]: port created: RtMidiIn-Client:midi/captur
Jun 10 12:59:01 patchbox jackdrc[379]: port created: RtMidiOut-Client:midi/playb
Jun 10 12:59:05 patchbox jackdrc[379]: port deleted: RtMidiIn-Client:midi/captur
Jun 10 12:59:05 patchbox jackdrc[379]: port deleted: RtMidiOut-Client:midi/playb
Jun 10 12:59:05 patchbox jackdrc[379]: port created: RtMidiIn-Client:midi/captur
Jun 10 12:59:05 patchbox jackdrc[379]: port created: RtMidiOut-Client:midi/playb
Jun 10 15:35:10 patchbox jackdrc[379]: port created: Pure-Data:midi/capture_1
Jun 10 15:35:10 patchbox jackdrc[379]: port created: Pure-Data:midi/playback_2
Jun 10 15:37:27 patchbox jackdrc[379]: port deleted: Pure-Data:midi/capture_1
Jun 10 15:37:27 patchbox jackdrc[379]: port deleted: Pure-Data:midi/playback_2
~

hw:Series is the device name of my external sound card.
Now, when i try to run the setup wizard to set it as my default device, ‘Series usb’ shows up, i choose it and it’s still in aplay --list devices, but it’s not in audio device settings or pulse audio through pacmd or pavucontrol. i’m really confused. also, still no audio from the bcm either.

0 Likes

#2

Hi, what did you change exactly in between the ‘working’ and ‘broken’ states in the OS?

0 Likes

#3

ok, update, I just reformated and started over because of frustration. Fresh install of patchbox and still the same problems. aplay list-devices finds my zoom g3 series but pacmd list-cards only finds the internal card.
Also! when i go into alsamixer and try to switch to the external, i get an error 'cannot load mixer controls: Invalid Argument.
Giedrius, in my last attempt, i believe all i changed was updating the pisound-btn to get hotspot working.
previously, when i was running the normal version of raspian, i didnt use pulseaudio and i didnt have these problems. i actually didn’t have pulse audio or jack so these two i’m not too familiar with.
Any ideas anyone? wanna start jamming with my patch!

0 Likes

#4

Any reason you must use pulseaudio? Jack backend is a pretty good choice for audio software. It could be that pulseaudio does not find the card, as it’s already in use by Jack.

What kind of patch do you want to run? Pure Data?

0 Likes

#5

i will be running lots of different pure data patches on it but nothing too huge or complicated. simple loopers and samplers. Can i just give up on pulseaudio? if so, i’ve read that removing pulse is a nightmare.

so i downloaded qjackctl and from there, i was able to choose my sound card

0 Likes

#6

Jack service is enabled to run in the background automatically and reconfigured when you pick your audio card in the patchbox config utility. Also Pure Data and Supercollider are preconfigured to use Jack backend, so they both should work out of the box.

0 Likes

#7

Looks like i got it everything working on startup! thats great! looks like qjackctl was the answer. I guess that would’ve been pretty obvious to most of ya.
BUT
Now im trying to get touchosc2midi working. It works great when my ethernet cable is plugged in (while my phone is connected to the patchbox hotspot), but as soon as i unplug the ethernet, pure data stops receiving midi messages. Any ideas?

0 Likes

#8

What IP are you using in your touch osc client?

0 Likes

#9

well, it finds patchbox as a host and its 192.168.1.27 (the same one i use to VNC with my comp while the ethernet cable is plugged in)
when i connect through vnc and the hotspot, its a different IP: 172.24.1.1
I tried to use this IP with osc2midi and it didn’t work.
maybe i need to switch the IP or something? when i am not connected to any wifi or ethernet with pi (but still connected with VNC through hotspot with the 172 IP) and type touchosc2midi in terminal i get an error:
Runtime error: default interface not found. check your network or use --ip switch

0 Likes

#10

any help would be greatly appreciated!
ideas anyone?

0 Likes

#11

ok, all good now, just added @touchosc2midi --ip 172.24.1.1 to the autostart and its working.

1 Like