Explain like I'm 5 -- Not getting any output/how does hardware work?

I feel like they skipped over some very basic information that should be covered in the tutorials.

The software seems to make sense but I can’t find anything that explains the hardware.

Like, which input and output is A? I assume it’s structured the way the LEDs are?
(midihub)
in A > A out
in B > B out
etc.

The ones straight across from each other? Right?

All I know is I set the pipe up to filter everything but the clock and my input device isn’t controlling tempo on the other devices as I would expect.

It’s odd to me that they don’t explain anything about the hardware other than “the button”. I know if you’re super familiar with something the basics may seem obvious but come on? I was really looking forward with playing with my new toy.

Does anyone know of an “open the box, let’s get started” video?

Thanks in advance for your help.

Hey, check this video out:

The port order matches the LED letters.

Could you show us your current preset? I think you’re after something like this:

ForwardClockToAll.mhp (154 Bytes)

This accepts clock events from MIDI IN A, then through Virtual A pipeline it produces 4 copies of the event and forwards to MIDI OUT A - D. You may want to let through the Start, Stop, Continue messages.

1 Like

Thank you that type of video is what I was looking for.

I’m still troubleshooting and I think I know what that problem is.

Why wouldn’t midihub work with a quadra through?

I’m just trying to do the most basic thing, send clock to all devices.

Here’s what I’m trying to do:

Keystep > midihub A input (filter for tempo, note on/off only) >

Miduhub output A > input quadra through >
Quadra through output 1 > Circuit
Quadra through output 2 > Drumbrute

Any ideas on why this wouldn’t work?

Setup 2 (troubleshooting)
Put a clock generator on the midihub > Output A
Input A (keystep)> Filter for note on/off > Output A
Output A from midihub to Novation Circuit.

RESULT: Directly connecting to circuit responds to the clock only but still doesn’t doesn’t get note data from keystep on the input side.

When I plug directly from midihub out to one device I get clock, but not if I try to send to all devices with my quadra-through. I know the quadra-through works. Lights up blue and blinks to the clock.

I’m OK with techie stuff and basic MIDI, it seems like this should work. I’ve made sure the keystep is on MIDI channel 1.

Is the midihub doing something to alter the MIDI channel data without telling me? I would think if it’s “through” it’s not going to change the incoming channel and outgoing channel without being specified?

UPDATE: More troubleshooting, looks like you need to flash the pipe build every time you make changes for them to take effect even if the device is connected on the computer and you make changes to the pipes?

I got the midihub generated clock output to pass through the quadra through but something about the keystep note filtering made my drumbrute freak the heck out. Still troubleshooting.

UPDATE:

WOW there is definitely some kind of chanel remapping going on by default.

To troubleshoot I just added one pipe Input A > Output A, no filtering.

Keystep > MIdibub > qudrathrough > circut

Pressed some notes and it sounded distorted, now my Circuit is growling at me and won’t stop.

Screen Shot 2020-07-24 at 11.47.31 PM

Giving up for tonight and starting over tomorrow.

I have no idea why I would get a different result between Keystep>Circuit (expected behavior)
and Keystep > Midhub in A > (no filters) > Midihub out A > Circuit
(took out everything else from the physical and virtual chain)

I thought trying to go clock out to everything was a simple start, now it seems like getting vanila midi through is going to be a project on it’s own.

It’s only necessary before you unplug the device to get your changes stored in its memory, all editing changes happen in real time.

There’s no channel remapping happening, if there’s no pipes placed to do that.

Just try to do File -> New, put in FROM MIDI A, then TO MIDI A.

To inspect the events, you may put FROM MIDI A to USB A, to inspect the data in some MIDI monitor software. You could even loop back MIDI OUT A to MIDI IN B, and send MIDI IN B to USB B, and check the data in the MIDI monitor software.

1 Like

I think you’ve got multiple pieces of gear attempting to do things to the MIDI messages as they flow through. If you take the Quadra out of the equation, and just have the Keystep send notes into input A, and send those notes out output A, and also put a clock module onto output A what happens?

Hi Synthdad. You might see that I’m already there with my troubleshooting.

For some reason:

Keystep > Circuit

=/=

Keystep > Midihub I/O (as in screen shot, no filters) > Circuit

I’m not even just getting basic midi through. The circuit freaks out and holds notes at some ungodly fast tempo with the midihub pluged in but plays normally when I take it out of the chain.

Does that mean I got a broken one and need to return it?

Thanks for clarifying. I started seeing it update in real time while troubleshooting but it definitely was “stuck” at some point and not updating with app changes when I posted that comment.

Just try to do File -> New, put in FROM MIDI A, then TO MIDI A.

That’s what I did before going to bed and put in the screen shot. If from IN > to OUT doesn’t work as a simple through I’m thinking at this point it’s broken or something :frowning:

Try putting in:

FROM IN A -> TO USB A

and check the first port on your computer whether the events are as expected, you may use software similar to PocketMIDI or MIDIMonitor to see the events on your Mac.

1 Like

Is there any chance at all of there being a MIDI loop? Is Circuits output plugged in somewhere? Things like this could happen if the same events get forwarded endlessly in a loop.

Does Midihub’s activity LEDs indicate MIDI data getting received and sent at the DIN-5 input and output?

There is no chance of a midi loop in this case. I currently just have it as described.

Keystep > Midihub > Circuit

Midihub is set per screenshot above.

I mean, I think you’re onto something though, it kinda does seem like a midi loop where the commands are getting stuck.

It doesn’t help that I have no idea how to send an “all stop” message.

I would have to have a MIDI DIN interface for the computer, which I don’t have.

UPDATE: There is definitely something critical that I’m missing. Or isn’t working on the device.

Maybe it’s not getting consistent updates from the software?

After letting it sit overnight and confirming that everything works as expected when plugging the keystep directly to the Circuit, I launched the midihub software and confirmed the pipe, tested the midihub for MIDI through and it actually “worked” (midi though test).

So I go OK let’s test my luck and add the drumbrute.

Virtual A to output B, simple right?

Drumbrute doesn’t get start/stop message or anything. Circuit still does so that’s “good”.

Connect keystep to drumbrute directly. Get’s start/stop message no problem.

The LED’s for A i/o light when I hit start/stop but they don’t light for B

I’m really starting to think that this is a configuration issue between the software and the hardware of the MIDI hub.

Any ideas?

Current pipe screenshot:

I think you wanted FROM MIDI A -> TO MIDI B

FROM VIRTUAL A would provide the outputs sent to TO VIRTUAL A pipes around the pipeline. So in this case, there’s no data in Virtual A port.

2 Likes

Not true! since I got mine there was a couple of Editor updates and a hand full of firmware updates!! Just stay alert and they’re coming :wink:

Patience and perseverance, and planning and testing… this things do get time to get used to, terminology, pipes routing… ( honestly writing this down in no arrogant way)

1 Like

@Jay_B to really understand what’s going on you’re going to have to do a MIDI IN A -> USB OUT A and run MIDI Monitor (if you’re on a Mac) to see what is being sent from the Keystep.

Also - what happens when you connect the Keystep directly to the Circuit? Are you hitting play on the Keystep, or simply pressing notes?

Do you have any other synths you can connect in place of the Circuit?

Have you tried re-flashing with the latest firmware?

what happens when you connect the Keystep directly to the Circuit? Are you hitting play on the Keystep, or simply pressing notes?

I can do both and they work as expected. I’ve been using that setup for a while.

you’re going to have to do a MIDI IN A -> USB OUT A and run MIDI Monitor (if you’re on a Mac) to see what is being sent from the Keystep.

OK I’ll see about that.

I did end up changing from virtual A out > B in
to
A out > B in
and was able to get “through” After I got that and could control the tempo with my keystep on both devices I had to jam out a sesh and got sidetracked from testing for now.

Do you have any other synths you can connect in place of the Circuit?

I’ve got a little midi font generator and a volca kick I will eventually be integrating into the setup. I wanted to keep it simple to start.

Next on my list is to try to figure out how to get the filters to work.

If the setting is check-marked it should pass through, correct?

Thanks for your help guys. I will get the hang of it eventually and will post in the community if I get stuck. I was just expecting it to work “As seen on TV” out of the box.

Once I get up to speed I’ll be around to help others :slight_smile:

In the filter pipe, if the box is checked, it drops/filters out the type of message the checkbox belongs to.

2 Likes