Error during pisound software install


I tried to use the command “curl | sh” but that gives an error
(rpi3 with pisound mounted in self printed case - latest raspberry OS, update/upgrade done - so Internet connection is fine)
The error is:
“sh: 2: Syntax error: newline unexpected”

I also tried sudo apt install pisound-btn : cannot find pisound-btn packet. (same without -btn)

What can I be doing wrong?

It seems to work fine for me… The script didn’t change for a while. Try executing the main commands manually one by one:

wget -q -O - | sudo apt-key add -
sudo wget -q -O /etc/apt/sources.list.d/blokas.list
sudo apt-get update
sudo apt-get -y install pisound

Let us know if these run ok, or which one of these produce an error.

Thank you for your quick reply!

The first line already gives an error:
Warning: apt-key is deprecated. Manage keyring files in trusted.gpg.d instead (see apt-key(8))
gpg: no valid OpenPGP data found.

Try running these commands:

curl | gpg --dearmor | sudo tee /usr/share/keyrings/blokas-archive-keyring.gpg > /dev/null
echo "deb [signed-by=/usr/share/keyrings/blokas-archive-keyring.gpg] rpi main" | sudo tee /etc/apt/sources.list.d/blokas.list > /dev/null
sudo apt update

after first line:
gpg: conflicting commands
(then % Total… and some numbers)
(23) Failed writing body

That’s odd, I get this:

I get the same numbers, except the speed numbers (7173/7173 instead of 8551/8509). But with those errors… I’ll try another reboot… nothing.

Now, something that gets my attention when doing apt update (I have to translate it because my OS is set on Dutch) , after the request to get http:/ rpi InRelease [3.922 B]
I get the error: "could not be verified because public key is not available: NO_PUBKEY 37808098F560908A
Then the same thing with GPG.

Hmm, I’ve just tried flashing this OS build:

And ran the same commands as before:

curl | gpg --dearmor | sudo tee /usr/share/keyrings/blokas-archive-keyring.gpg > /dev/null
echo "deb [signed-by=/usr/share/keyrings/blokas-archive-keyring.gpg] rpi main" | sudo tee /etc/apt/sources.list.d/blokas.list > /dev/null
sudo apt update

They went all fine… Also I tried running curl | sh, it did give a warning about apt-key being deprecated, but overall, it went fine, without any errors.

Any ideas what could be different on your system?

No idea what is different. I used a brand new SD card that I flashed with the official raspberry Pi imager. I took the full OS with Pi Desktop.
To make the story complete, when I unpacked the PiSound, I first hooked it on my Rpi400, just to test. I have the same OS on that system and everything went well, all installations worked. I managed to create a little Python program that could play some notes on my old Roland SC55 (don’t want to mess with the Integra-7 as long as I’m not sure :slight_smile: ) , while changing patches on different midi channels. All fine.
Then I hooked the PiSound on the Rpi3 with the forementioned new sd card. The rest is what you know.