[Download] Midihub Firmware 1.11.7

PM’ed. We’ll aim to finalize and release the fix for Win10 early next week. :slight_smile:

I also got the message “Unexpected error occured while flashing the firmware, code -1, stage 6!” with Ubuntu 18.04 when flashing firmware 1.11.7. The second attempt was successful :slight_smile:

What was the editor version you used? We just released 1.11.5 which should improve the flashing :slight_smile:

1 Like

I used 1.11.4. Thank for the hint and your fast support! :+1: :slight_smile:

1 Like

Just to let you know the latest editor and firmware update all okay, this time with no errors on Windows 10 desk-top. Had the previous errors a couple of times, that I eventually sorted out, on the prior update.

I was thinking it may be useful to have a section that could be used for midihub users could ask other members advice how they would connect up there hardware if they had the same set up. As they saying go’s, there’s more than one way to skin a cat. I have seven pieces of hardware with various 5 pin midi in and outs. I think with a total of thirteen 5 pin midi sockets between them. My midihub has all eight in use at the moment and I have hardly touched the surfaced of the midihub’s potential.

Thanks for the prompt replies on the member community web-site.
I’ve learnt a lot just reading all the posts.
Keep up the good work.


I’m running into an issue where I have installed editor 1.11.5 (also tried it with 1.11.6) and I am trying to update the firmware to 1.11.7 but the Editor can’t seem to find the Midihub when it’s in “update” mode.

Screenshot_2 .

It does find the device when I press Connect in normal mode. I get notified that there’s a newer firmware available:


I can also find (two) Midihubs under the following section in Devices on Windows (10).


That applies to both modes.
Not sure what to do right now other than try and try again but I can’t seem to make it work. I am essentially unable to do step 5 in the process.

Hey, you have to use the Midihub Flasher tool with beta Midihub unit for upgrading the firmware. :slight_smile:

1 Like

:scream: I am so stupid!

I changed computers (went back to my old laptop, long story) and I didn’t have the Flasher installed there for some reason so I completely forgot about it.

Updated firmware to 1.11.7 with Editor 1.11.6 and connection is established.
Working on Windows 10 (not latest unfortunately, can’t update this old thing) just fine!

:heart_eyes_cat: :heart_eyes_cat: :heart_eyes_cat:


I think we should create a dedicated thread for the tool and the beta testers to refer to. :slight_smile:


Thanks much! I’ll give it a try.

1 Like

Windows 10 Pro x64, Editor 1.11.6 - Upgrade to 1.11.7 worked perfectly.
Thanks for the fixes!


Hi. I’m unable to install it. I’m using Windows 1. Anyone care to help me out plz? I can’t seem to get this thing working. Kthxbye.

Try installing x86 vcredist from https://www.microsoft.com/en-us/download/details.aspx?id=53587

Thanks but “setup failed”.

Please create a new topic on the issue you’re facing with the steps you’re taking and exact errors you’re getting, and possibly some screenshots, so we can better understand what’s failing and find a solution.

Is there a way to determine what MIDIHub firmware is currently loaded into MIDIHub? I couldn’t find anything.

When you connect to the editor - look to the lower right of the editor window - it will be listed there.

1 Like

Found it. Thanks! Just wasn’t sure whether I had already upgraded or not and obviously never looked down in the lower right hand corner.