[Download] Midihub Editor 1.11.8 & Firmware 1.11.10

Hey guys! We have an update for Midihub Editor & firmware - it introduces importing pipes straight from Patchstorage.com, automatic firmware upgrade that downloads the new firmware image and keeps the memory contents, and some fixes in the new firmware version too! Detailed changelogs are available below.

Downloads

New Firmware Upgrade Procedure

First make sure to install the 1.11.8 editor. Then on connecting to the device, if there’s an update available you’ll be offered to start the upgrade procedure. Confirming it will then go on to download the new firmware image, save a backup of the current memory contents to disk, do the flash procedure and restore the backup back into memory.

Otherwise, you may also do Help->Check for Updates Now... while connected to Midihub to start the automatic upgrade procedure.

Offline Upgrade

Download firmware image linked above, and do Device->Flash Firmware while Midihub is in regular mode. It will also backup and restore the memory data automatically.

Note: Starting firmware upgrade when Midihub is in bootloader mode will not save the memory contents, just in case, there’s a warning message when doing that to remind of this.

1.11.8 Editor Changelog:

  • Patchstorage pane for browsing and importing presets.
  • Automatic download and upgrade of new version of Midihub firmware.
  • Firmware upgrade process now moves the memory contents to the new version.
  • Fixed Editor launch issue on Raspberry Pi Zero.
  • Added optional --skip-udev-rules-install to avoid first-run root permission request to set up the access permissions to be able to communicate with Midihub as a regular OS user process. Useful in case of previewing the Editor without hardware.
  • Small UI layout fixes to improve compatibility with high dpi and regular displays.
  • When a firmware upgrade is available, the message will show the current version number too.
  • Fixed some memory data backups not importing properly.

1.11.10 Firmware Changelog:

  • Fixed an issue with Dispatcher and MicroScale pipes getting stuck notes in some circumstances.
  • Fixed incorrect LFO waves when depth is set to 0.
  • Fixed incorrect Square LFO wave when phase is non-0.
14 Likes

All good ! macOS 10.13.6 High Sierra.

Much more easy now to update firmware (and automatic), just installed new editor then Device > Connect and was prompt to update firmware (with all save memory content and restored back in the end) :wink:

Nice touch the Patchstorage integration :wink:
Thanks !

4 Likes

And if the computer isn’t connected to the inter web? You need to make the firmware downloadable on here as usual

Good point, edited the original post with offline upgrade information.

Thanks​:+1::+1::+1::+1::+1::+1::+1::+1::+1::+1::+1::+1::+1::+1::crazy_face: that should be 15 characters surely.

1 Like

Thanks guys! :heart_eyes:

1 Like

hej,

I think the link you added points to firmware 1.11.0 or is it just a typo?

Yes, it was a typo… Edited it to the correct 1.11.10.

Hi Giedrius,

when I try to install the firmware upgrade* 1.11.10 I get the following error message:

image

Midihub stays in bootloader mode (all LEDs active). When I hard reset it, it comes back (all data preserved).

Cheers SF

Edit: *) using the automatic method

Hey, what is the current firmware version on the device you’re upgrading from?

It’s 1.117
image

I did not try the manual approach yet.

Cheers SF

It happens 100% of the time?

It happened all the time in the original setup where Midihub is connected to a powered USB hub. I connected it directly to the USB dock of my notebook now (using a different cable) and the process went through until…

image

BUT: after re-connecting the firmware update seem to work:

image

This used to happen before with other FW updates. I should add that all my pipes are gone (of course I made a backup and can get them back).

Cheers SF

Edit: It’s getting worse… the backup file isn’t processed:

image

An older one worked. I think most of my config is rescued.

Could you send me the non-working .mhd file via PM?

Btw, the editor saves backups just before the upgrade to this location on Windows:

C:\Users\<your_user>\AppData\Local\Blokas\Midihub Editor

You should find the most recent one there. :slight_smile:

It’s interesting how you can get these issues happen so consistently, could I send you a special editor build that would write a detailed log that would help us see how to get it working well for you?

I just sent the file.

C:\Users<your_user>\AppData\Local\Blokas\Midihub Editor

Inside the backup folder you mentioned there are 3 files but none of them can be imported, all with the same error message I’ve seen before. Send me the editor build, I’m pleased to help improving the Midihub.

Cheers SF

1 Like