Disabling pulse-audio. 'gtk-launch not found' [solved]

I noticed that pulse-audio sometimes appears in ‘top’, and uses a fair bit of CPU, and I see the sink and source in QJackCtl (just monitoring) There’s an option in patchbox-config to disable it…

pulse-audio-off: Keeps the Pulse Audio's Jack Sink and Source disabled v1.0.0

…when I run it it ends with gtk-launch not found. Is that a problem or has it worked in fact? It’s not clear when pulse-audio pops up, so I can’t easily test.

Had the same issue. Only works if you are in the desktop environment.
So basically startx, then run a terminal from there and run the command.

Thanks, I’m running headless though, via VNC to get the desktop and it gives the ‘not found’ error there. X must be running somehow. Not a showstopper, but it seems like a useful function to have.

Try sudo apt install libgtk-3-bin, looks like patchbox-cli is missing this dependency.

Also you could run the commands manually, the source code for this module is available here: https://github.com/BlokasLabs/patchbox-modules/tree/master/pulse-audio-off

1 Like

Thanks yes that’s got it. I was using sudo killall pulseaudio which did the job too.