Digitakt pattern change


I guess people with a digitakt will know this, when your digitakt is in slave and you change a pattern on your master device, the digitakt waits 1 pattern (1bar or 4 bars) to switch the pattern. for me this is a problem because i want the digitakt to switch patterns instantly together with my master device.

anyone knows how to do this with the midihub? That’s practically the reason why i bought this device so I hope someone can help me out with this.



Hey, this discussion is for Rytm but is probably relevant for Digitakt too: Xform PC -> Stop, PC, Start :slight_smile:


I checked this thread but this guy is basically trying to achieve this with his computer… this is not what i want :slight_smile:
He wants that the pattern changes directly when you press the button of the pattern change (in direct mode). This is not my goal, I want that the pattern changes at the end of the master pattern (that comes from my Analog Rytm). i tried it with the sync delay pipe like you mentionned in the other thread and i must say it works 7 out of 10 times… But ofcourse that’s not good enough :slight_smile:

btw: the Rytm does respond to pattern changes as slave to every end of a pattern from another master, the guy in the other thread really wants it immediately when you press the pattern change button, i want to press a button and want it to follow the master in 1, 2 or 3 bars (all steps it has to go till the switch to the next pattern). So on Rytm this works fine as slave, on digitakt it does not.

I could swith my setup and make the digitakt master of this chain, BUT i play for so long with the Rytm in my setup and always liked that i need 2 buttons to switch a pattern, on the digitakt you need to press 3 buttons, first select bank, then bank number and then pattern number. I know, it’s a small difference but for me it is bigger than that :slight_smile:

anyway, thanks for your help, i will try some more things and come back if it’s not working how i want.

I think every place where PC is mentioned in the thread is actually referring to a Program Change message, not Personal Computer. :smiley:

Let us know how your experiments work out. :slight_smile:

Pretty much the only solution is a stop message, then a program change message, then a start message. Octatrack is the same way, it plays through its pattern, then changes. This is configurable but it takes at least one pattern step, cannot make it immediate. I’ve gotten mine to switch instantly using this method.

I don’t know when the rytm sends its program change, but if you transform it into those three messages you should be able to get the digitakt to switch right when the program change is sent. If it sends it a few bars before you need the change, I can’t think of any way to fix that with midihub. Midihub doesn’t know how long your patterns are. Hopefully it is right when you want the switch.

I guess you need two transforms to make two additional messages out of one. I would try turning the program change into a stop ‘before’ and then the next transform a ‘start’ after.

There may be side effects to doing this, can’t remember. I mostly gave up on elektron sequencers. They are only superior to toys.

1 Like

FYI, I already tried with the valuable help from the blokas guys, but never achieved it. Check here:


Could you maybe explane exactly how to do it? i need to add 3 transform pipes? 1 stop, 1 program change and 1 start, right?
I don’t really get what i need to choose in all the other options in the transform pipeline like the unused and argument options… and also the mode, should it be on insert before or after or replace?
Could you maybe check these 3 pictures in the dropbox link below and see what i did wrong or mention what i should change to make this work…

Thanks in advance

From the pictures you are not transforming anything. You are telling it to turn a start into a start, etc… You need to turn the program change into a stop, insert before, then turn the program change into a start, insert after. Think just those two transforms would likely do it.

1 Like

‘Prioritize Real-Time’ should be off in this case, so the order of messages is retained. Otherwise, MIDI messages belonging to ‘Real-Time’ class would get priority over all the rest of the messages like Program Change.

hey,thanks for the help already! Yeah, I’m normally good with midi but this midihub is a bit of a pain in the ass for me at the start :smiley:

So, I tried everything you guys mentionned and still no luck. sometimes it changes correctly together with the Rytm pattern, and sometimes it does the same as usual, waiting for a full pattern to change to the next pattern. with the things you told me i need to do it also get’s out of sync from the moment it switches a pattern… Could this maybe have something to do with the insert before and/or after setting? because it’s just like the pattern starts a little bit too early.

I again added a folder with all my settings in the pipelines. Could you maybe check again if everything is correctly? there is also a video where you can see that the sync is lost from the moment it switches. my main clock is the erm midiclock+ and sends only clock/start/stop to the rytm (and octatrack). The rytm only need to send program changes to the digitakt, i have entered several filters between the output of the rytm (midi C) and the input of the digitakt (midi D), only program change and clock/start/stop/continue are not filtered and sent to the digitakt from the rytm. I also filtered all midi channels except channel 16 which is used only for pattern change send on the rytm and pattern send receive on the digitakt.

I tried to explain as good as possible, i really would like this to work as this would totally complete my live setup and how i want to play :slight_smile:

thanks in advance


Also, have been messing in opposite direction, digitakt sending program changes to the analog rytm (mk2) and this works flawless… i know it’s a digitakt problem but looks like the people from the other threads here have the same problem with the rytm (maybe mk1?). for me this works perfect, only downside is that i am so used to play with my rytm as master… so help still would be appreciated.
1 thing that would also work and that i would find super usefull is to select a pattern on the digitakt and then with a cc message select the next pattern with a button via midi, unfortunately there is no cc command for increasing or decreasing patterns on elektron gear. I did just found out about a pedal that can do that, the source audio soleman. Anyone has experience with that or tried it?

Hey, could you upload the .mhp file here in a comment? It’d be easier to inspect the preset. :slight_smile:

rytm master.mhp (336 Bytes)

This is it. If you need an explenation of what is all connected and what are the purposes, please let me know. For The problem i have it’s the connection between input C to output D (Analog Rytm to Digitakt)

The preset you have should produce the correct sequence of STOP, PGM CHANGE, START messages.

There’s a more elaborate way to do the same, but with some timing control for the events. There’s an example showcasing it, see in Midihub Editor: File → Open Example…, open ProgramChange to Multiple Ordered Events.mhp.

I’ve uploaded it to Patchstorage just now too: PGM Chg to Timed Start, PGM Chg, Stop sequence | Patchstorage, you may append it directly in your preset through the Patchstorage Browser pane.

Set the channel as needed in the CH REMAP pipe. Try playing with the Delay’s time argument to see if some larger or lower values make a difference and make it work as expected.