Delay pipe 100% wet

I have a virtual IN pipe that only keeps note on/off messages, then filter out all channels except channel 3. This is sent to my virtual out pipe “delay”. This works.
My virtual in “delay” first remaps the notes from channel 3 to channel 2 then goes into the delay pipe. Works.

Now, when Delay Wet is set to 50% I expect the remapped notes + their delayed copies but I only have the exact same notes without delay:

While I expect the remapped notes + the delayed copies based on delay time.

When I set delay to 100% wet, I get only note off values:

While I expect to have only the delayed copies on and off based on delay time.

I would like to base my delayed notes on the notes from channel 3 and bring the delayed notes into channel 2, 100% wet. Did I overlook something?

(Edit: Forgot to say I get the clock from another virtual IN port.)

1 Like

Update: looks like it works when overdub is enabled. Is this the correct behavior?

Yes, when Overdub is on, new notes are getting accepted into the delay loop. For regular Delay effect, Overdub should always be on. For using Delay pipe as a little ‘looper’ effect, with feedback set to >= 100% and infinite repetitions, Overdub can be used to control whether you’re inputting new notes into the Delay loop, or just playing on top while the other notes loop.

1 Like

Thank you very much, @Giedrius, makes total sense! I only run in doubled clock now because my target port already has clock for sequencing and it doubles up because of the clocked delay. I take clock from midi in A, forward it to virtual out A so I can send it to all other midi out ports. I have to send it also to my virtual out “delay” port which also receives (only) note information from a virtual in. My delay pipeline has virtual in “delay” to combine both and is then sent to a midi output. Any idea how to prevent the double clock?

1 Like

Put a Filter pipe to drop clock, start, stop, continue, song position pointer, song select, MIDI timecode messages after Delay pipe. Maybe just have it pass through Note On & Off messages. :slight_smile:

1 Like

Of course, how could I just not try that out myself :man_facepalming:t3:
Thanks @Giedrius, the Midihub is rocking it!

1 Like