Csound and pisound


#1

Hi my Friends
it is time to write a few lines on my first experience with Raspberry Pi3 and PISOUND.
I had a bit of problems installing Csound … I tried to build/compile the latest version of Csound and CsoundQT … I gave up !!
Now I’m running an older version [6.03.2] of Csound and version 0.8.3 CsoundQT … at the moment it is important to try the interface.

I am running Jack and then selecting Jack from CsoundQT … running a simple test I had an error concerning the sample rate … which I changed in the Csound program …

I tried Pure Data as well just to see if any difference were there, and it runs smoothly as always.
No big difference.

By now I must say I haven’t done much … but I will try to develop something with it…
and I will surely try again to compile the new version of Csound.

If any of you is interested here is a link on how to build something similar to PureData in Csound.

http://www.csounds.com/journal/issue18/beagle_pi.html

By the way … is the “BUTTON” usable in other ways? how?
Ciao Mattia


First pisound experiences
#2

Hey, we will try getting Csound to work during the next week and we will let you know how that goes.

The sample rates supported are one of 48000, 96000 and 192000. The sample rate must be the same for both input and output.

The button behavior is customizable - http://wiki.blokas.io/index.php/pisound#The_Button

Just change the following scripts as needed:

/usr/local/etc/pisound/click.sh
/usr/local/etc/pisound/hold.sh


#3

Hey,

I was able to get Csound running using jack server. First I started jack server (as described here). Then I started CsoundQt, in its configuration, changed it to use jack audio implementation. For some Csound examples I had to change the ‘-b’ and ‘-B’ values in order to make them to run. For example when trying to run ‘Chowning-Stria.csd’ I was getting:

*** rtjack: period size (-b) must be an integer multiple of ksmps

ksmps was set to ‘10’ in the patch, so I had to change the ‘-b’ value in configuration from 1024 to 1000, so it divides without a fraction from ‘ksmps’ value. Then the patch started fine.

To get Csound install, I did:

sudo apt-get install csound qutecsound

Let us know what messages you are getting or what steps can we take to reproduce the issue, so we can help you out getting Csound to run. :slight_smile:

p.s. The button could be reprogrammed to start Csound patches instead, by modifying the /usr/local/etc/pisound/click.sh


#4

i will be using csound for the STk opcodes when mine arrives i will report back