CRASH: Editor will crash when selecting Virtual output source


I received my midi hub today and immediately updated to 1.15 along with Editor.
Sometimes, when I drag in a Virtual Output and click on “Destination” to select it, Editor will crash without warning.

It happened 3 times, each time was when I clicked on destination for the first time on a newly dragged in Virtual Output. The project was recovered when restarted and I was able to select the Destination on the second try, every time.

Hey, haven’t seen this yet. :slight_smile:

What OS are you using?

What are the exact steps you take?

It just happened again.

System: MacOS 14.3

  1. Drag in a “FROM VIRT” pipe
  2. Click on the pipe to open properties
  3. Click on the “Value” field of the “Destination” property
  4. Crash

Do you get some error message? Or a macOS crash report? Could you attach it here or send it to us by email?

Here are 3 crash reports attached.
The stack trace is pretty explicit, good ol’ SEGFAULT, should be easy to fix ! (21.6 KB)

Could you post a screenshot of how the Editor looks like soon before the crash?

What is the screen resolution you are using?

I can’t reproduce this crash at all, and the callstacks don’t immediately point to something obvious. Given that the code involved didn’t change for quite a few releases with no similar reports, I wonder what else is going on.

Does anyone else encounter such crashes?

I just updated the Editor and firmware to 1.15.0, then read about this crash and tried to reproduce it. The first time I tried, the editor crashed, but I haven’t been able to duplicate the crash (and probably not the specific mouse drags and clicks). I’m using the Linux AppImage in Linux Mint.

I’ll reply again if I can reproduce the crash.

1 Like

I have 3 screens. My main one is 2056x1329 (MBP Retina Display). The editor window is not full screen.

Here is a screenshot of my editor. It did not crash this time…

Hmm, I’ve spent half a day on our 14.3.1 Apple M1 MacBook Air with 1.15.0 Editor, interacting with it in many ways, including putting the Editor on an external screen, and didn’t hit a single crash…

Is there something else that can be unique to your setup? Have you overridden some default OS configurations or enabled any experimental features (like Pointer Authentication) that might have an impact?

Nothing that I can think of… and @steve777 managed to crash it too… on Linux!
That being said, I’m a dev too and my machine is pretty much loaded with dev tools, but I never had this issue before, and I can’t think of something that could relate.

Also, Apple fixed a text related bug in 14.3.1 that was introduced in 14.3, maybe that’s related (it doesn’t look like it is at first sight, but who knows)?

I’ll update to 14.3.1 and see if it ever happens again.

1 Like

Editor just crashed while I wasn’t actively using it (focus was on other apps for a while).
Midihub was connected and clock signal was coming through.

Crash report attached

Midihub (6.9 KB)

What output do you get in Terminal if you execute this command:


I’m on MacOS 14.3, M1 chip

It just crashed again. Logs attached. This time I didn’t use my computer for the whole evening and I think Editor crashed when I pressed play on my dawless rig, with the midihub still connected to the Editor.
Midihub (6.9 KB)

I’ve merged the other topic into this one, let’s track this here.

It could be something else entirely though…

I would expect more users report the same crashes though if they occurred this often.

Let us know whatever thoughts come to your mind that could help us reproduce them.

The topic you merged was another issue I think.
It didn’t happen in the same context and the stack traces look very different.
One is an pointer authentication issue and the other looks serial related.

They’re both memory access related which likely share the same cause. It’s easier to track this within one topic.

I sent you a custom build for further debugging via PM.

I installed it and am running it. I’ll let you know if it crashes.
Also, just so you know, I updated to MacOS 14.3.1 this morning.

1 Like

It ran all day without issue. Maybe that was MacOS related after all!


Please switch to the regular 1.15.0 build, and let us know whether it runs without crashes now. :slight_smile: