Connecting to Midihub Failed! Error: 11


Trying to connect my Midihub to MacBook Pro OS12 and am getting the message - “Connecting to Midihub failed! Error: 11”

Updated to the latest firmware, restarted computer after doing so.

Any ideas?


Hi, are you using Midihub Editor 1.13.1?

Make sure you’re currently on Midihub Editor 1.13.1, then try to upgrade the firmware through the bootloader:

  1. Power off the Midihub using the slide switch.
  2. Keep the button on Midihub pressed down.
  3. Power on the Midihub using the slide switch.

If it’s in bootloader mode, all the LEDs should be lit up.

Download the latest firmware from [Beta] Midihub Editor 1.13.1 & Firmware 1.13.0

Then in the Editor, Connect to the device, do Device → Flash Firmware…

Find and select the .bfw file you downloaded.

After the upgrade is done, try connecting to the device again, let us know how it goes. :slight_smile:


Connected perfectly. Thanks so much for your help.

Kind regards,

1 Like

Were you on 1.13.1 before?

Yes I was, must have been the firmware on the unit itself?

It’s difficult to say what went wrong exactly, let’s keep an eye out if other users hit the same problem.

I just bought a Midihub and I am experiencing the same problem. I am on 1.13.2 in the editor and I flashed the firmware “MidihubFw_1.11.9.bfw” to the unit and the lights cycled and then they all blinked so it looked like it worked, but then I hit connect and still I get error: 11.

Any suggestions?

You should use firmware 1.13.1 from [Beta] Midihub Editor 1.13.2 & Firmware 1.13.1

Ok thanks. Worked perfect!

1 Like

New user and same situation here. Just received my Midihub. Went to the website to download the editor. It gives me 1.12.2. Installed and ran that and it tells me there’s a new editor version: 1.13.2. So I install that. Connect gives the Failed! error 11. Flashing the fw solves it.

I’m not easily deterred but that was a slightly confusing start. Now off to do some MIDI patching :slight_smile:

1 Like