Connecting hotspot to Lemur on iPhone

I’ve posted in the ORAC thread and it was suggested I should also post here.
I’m trying to connect the WiFi hotspot to my iPhone in order to use the remote MEC controller for ORAC with Lemur app.
I’ve enabled the hotspot in PatchboxOS.
It is not showing up under my “Wi-Fi” on my iPhone.
I’ve been advised the default IP is but this is not working with Lemur.
FWIW I’ve been able to connect using the rPi IP when it connects to my home WiFi however I am trying to set this up to work away from home and WiFi connections.
Anyone have any tips?

EDIT: I’ve managed to get it working the other way around. After resetting my pw Patchbox managed to find and connect to my iPhone hotspot which will do for now. Still interested in any hot-spotting tips and tricks for non wifi environments :slight_smile:

The hotspot should be enabled and on by default on a fresh Patchbox OS install. If you connect Patchbox to a WiFi, it automatically gets disabled, it can’t do both at the same time. Also, it works only on RPi3 and RPi3B+, it may work on ZeroW, but I personally haven’t tested it. It can also work with older Raspberry Pi’s, if a WiFi dongle is insterted which is capable of acting in ‘access point’ mode, usually it’s the bigger ones.

Try enabling WiFi hotspot again, follow these steps:

  1. patchbox
  2. go to wifi
  3. go to hotspot
  4. select up to enable it
  5. select status to see the current configuration.

Let us know if this worked.

did you ever get this figured out? i’m having the same problem. even tried a fresh patchbox install and still no hotspot showing up. :frowning_face:

No my iPhone never saw the hotspot. I found it more reliable to go the other way - i.e. have Patchbox connect to my iPhone personal hotspot as default WiFi connection.

1 Like

Thanks to @whofferbert post here: MODEP no longer running following rpi-update we have figured out the hotspot issue. Turns out the script for starting the hotspot was exiting early due to there being no Pisound board attached, in order to be able to flash its LEDs indicating whether the hotspot is getting enabled or disabled. Needless to say it was not the intended behavior. :slight_smile:

I have just pushed out a fix to pisound-btn package (version 1.09-2), which contains the scripts to start and stop the hotspot.

Try doing:

sudo apt update
sudo apt install pisound-btn

Then run patchbox and (re-)enable the wifi hotspot, it should work this time.


awesome! thanks so much. will give this a shot when i get home from work today.