Connect Roland Interface to RPI


#1

Hi,

I have a usb interface that I run a condenser mic through to record vocals. Typically in ableton im used to just plugging on the interface and I can select on an option saying audio input device.

Can someone tell me how to do this on a Linux system that runs on RPI3?

im running this code:

  1. ecasound -c -f:16,2,44100
    -a:1 -i monitor-track.wav -o alsa \
    -a:2 -i alsa -o new-track.wav

im running this code but ecasound says Unable to connect: No inputs in the current chain set up?

Many thanks,

J


#2

Hi, most likely you have to clarify the exact audio device to use, probably using -i alsahw,2,0 instead of -i alsa argument. See arecord -l to figure out which value instead of 2,0 to use for the audio device you want.


#3

where do i run arecord -1 in the terminal, will that tell me what to use?


#4

It’s not -1, it’s -l (first letter for ‘list’). It will list all the input audio interfaces that your system sees, then you can figure out which number ID to use.


#5

Thank you! I’ve got something working with:

ecasound -B:nonrt -c -f:16,2,44100

              -n:VocalTest \

              -a:1 -i alsahw,1,0 -o alsa

I can here myself smoothly but theres too much of a delay. if I run:

ecasound -c -f:16,2,44100

              -n:VocalTest \

              -a:1 -i alsahw,1,0 -o alsa

I get a warning saying warning: ALSA recording underrun, some audio samples were lost! Break was at least 1731774209.63.

And a lot of audio artifacts

what else can I try?