Chromium issues on patchbox beta 2020-11-23

Hey all,
I’m setting up a RPi 4B 8Gb system specifically for use of recording, programming and music programming/ midi sequencing.
I haven’t found an SSD to install just yet but I’m running on a 128gb sd card (SanDisk microSD card ultra 128gb class 10, A1) with a couple 32gb thumb drives as backup, using an RK61 in wired mode, and a Waveshare 7.9inch capacitive 1280x400 screen
For normal operation everything seems good to go, the screen and touch are scaled right, keyboards fine (although I have to relearn how to use a small format, the function key is killing me haha), wifi is connected, etc etc

My two biggest issues are:

1 I keep getting a jack/sound device errors depending on the program (this one I’m confident I can figure out but if anyone has any tips for specifically the beta 2020-11-23 build I’d appreciate it; I should have probably gone with the 4gb for all the trouble it’s been). The Waveshare screen has an audio out but I’m fairly certain I disabled it in the set up. I’m planning to run the RPi’s built in audio on the go and use a usb connection to my Focusrite Scarlett 2i2 when I’m interfacing more gear down the road but at the moment I might just have to settle for Bluetooth headphones

And 2: I discovered this while troubleshooting issue #1 because I wanted to play a video to test the sound but I can’t open Chromium, it starts and then times out. I need this to work properly so I can connect to my digital backup account most importantly and also any other GUI based internet use. There’s 100% a chance that’s it’s just an issue with the beta being a workaround to get patchbox to work on the RPi 4 8b but it is a deal breaker at the moment. I don’t want to build a killer deck and risk losing all my recordings because they aren’t backed up (I can probably SSH into my phone or Chromebook to route the backup to my Google drive but that’s a lot of room for error because my Linux is rusty as hell/incredibly unnecessary when I know it can be done simpler)
Also if I run" echo $DISPLAY
chromium " I get a value of 0.0 so it could also be the OS not passing on information to Chromium about the display…

Side note I’m still waiting on a couple parts for expanded functionality but I definitely foresee the USB midi to control voltage module I’m tacking onto the back to interface with my modular gear to be a tricky operation as well

TL;DR: probably easy solutions I can’t find but would appreciate any help

Hi, make sure you’re using large enough buffers for Jack, so it’s stable for the software you use it with.

Does chromium produce any errors in the terminal when it’s started from there?

1 Like

I set the buffers at 512 but I’ll try the next step up
As far as chromium goes, when I run" sudo chromium-browser " I get
" BlueALSA detected - Disabling audio sandbox
[2626:26240502/] Running as root without --no-sandbox is not supported. See HTTPS:// "
If I follow to the reported bug link the parts that are probably useful are behind a developer wall and probably only pertain to mainstream distros

Don’t use sudo for chromium, use it only where it’s strictly necessary. :slight_smile:

1 Like

I’m reaaally rusty haha. Same result though, just 4875:4875 are the first set of numbers

Please post the entire output when run without sudo.

Blue-ALSA detected - Disabling audio sandbox
[4875:4875:0502/] Running as root without --no-sandbox is not supported. see

What does this command print in the same terminal?


root 20characters

You’ve somehow logged in as root in the terminal (like sudo su was executed there). Close it and start it again. whoami should print patch, then try running Chromium again.

closing terminal didn’t help but I backed out of the GUI with " sudo shutdown -r now "
typed " patch " which also did nothing so I did ctrl+z
and then " sudo startx "
and it booted entirely differently…
I set it up to launch directly into the GUI without password for ease of use but I must have misdirected it to automatically assume root
Thanks for your help x1000 I’ve been beating my head against a wall all night

You should just use startx, without sudo.

1 Like

sudo forces a root command doesn’t it…

What do you mean? :slight_smile: