CEAMMC lib on patchbox os

Hi patchbox lover

I just discovered the CEAMMC which is both a list of ( really nice ) externals for puredata and a new distribution of puredata with theses externals included.

These externals looks really nice ( nice synth, audio effect, UI … ) and very complete.

I can’t get them on patchbox os :

  1. I tried first to install the complete pd-ceammc with snap from this link
    but snap command give a segmentation fault :frowning_face:
  2. I tried ton compile directly from source …
    I got this using ./autogen.sh
    configure.ac:173: error: possibly undefined macro: AC_LIBTOOL_DLOPEN
    If this token and others are legitimate, please use m4_pattern_allow.
    See the Autoconf documentation.
    configure.ac:174: error: possibly undefined macro: AC_LIBTOOL_WIN32_DLL
    configure.ac:175: error: possibly undefined macro: AC_PROG_LIBTOOL
    configure.ac:242: error: possibly undefined macro: AC_CHECK_LIBM
    autoreconf: /usr/bin/autoconf failed with exit status: 1

Does anyone find to use to use these externals on patchbox os ?

Thanks

This worked on Patchbox OS:

sudo apt update
sudo apt install snapd
sudo snap install pd-ceammc --edge --devmode

After this, I see the .pd files installed in this location: /snap/pd-ceammc/current/lib/pd_ceammc/extra/vasp/vasp.pwrap.pd

I’d recommend just getting the snap software sorted out. :slight_smile: Check if there’s any updates, etc…

Thanks Giedrius

unfortunately snap give a segmentation fault
the version of snap is 2.37.4-1+rpi1

Maybe i should try with a clean version of Patchbox OS ?

!! EDIT !! I removed and re-install snap and it seems to work !

1 Like

Thanks again Giedrius

Finnally it compiled. This custom version of puredata is broken, but at least some externals are here ( soundtouch, vasp, fiddle~ , autotune … etc … ). I am still confused because the ceammc folder, located next to the vasp one is full of help.pd file , and I don’t have the externals of the pure ceammc library ( array, ceammc.string, fx.wahwah ., etc … )
I started to search on the disk any of theses files but they doesn’t exist. Only the documentation help was compiled. Thanks

There’s a whole lot of these libraries:

find /snap/pd-ceammc/ | grep \\.so
...
/snap/pd-ceammc/4/lib/i386-linux-gnu/libatm.so.1
...

i386-linux-gnu is not really what you want for Raspberry Pi, most likely this package is incorrectly built. :slight_smile:

When you say ‘Finally it compiled’, do you mean you are building it locally now?

sorry, “finnaly it compiled” means that snap was finally working.
About building it locally, I followed this message from github ( link that tells me to use CMake in order to build ceammc. I did, but i get a CMake error.

i386_linux-gnu/libatm.so is the library that give Snap, but it is not usable on raspberry pi ( arm ) . That’s it ?

Yes, the ‘snap’ that gets installed is actually meant for 32 bit x86 architectures. The package maintainers should be informed of the issue.

Building it locally from source may produce binaries for the ARM architecture…

The snapcraft.io page says that the last update was on july 5th 2020 :upside_down_face:

I will try to solve the CMake error using a standard Raspbian Distrib. The library is so awesome …

EDIT : I tried the soundtouch~.pd_linux library and it is not working, so probably is x86 architecture too : This is the PD console /snap/pd-ceammc/4/lib/pd/extra/ceammc/soundtouch~.pd_linux: /snap/pd-ceammc/4/lib/pd/extra/ceammc/soundtouch~.pd_linux: cannot open shared object file: No such file or directory

Finnally I succed in compiling pd-ceammc using an standard raspbian os, and it works.
I get a .deb file to share with the community. I will try to install it on patchbox os.
Here is the link to download it … download
note that there is also a .so library in this shared folder, that you had to copy in order to make it work.

It works :slight_smile: on patchbox OS . I had to copy mannually the libtiny-process-library.so file into /usr/lib/pd_ceammc/extra/ceammc .