Can't install Modep. "Unable to locate package modep"

Because of issues with my Behringer UMC204HD interface that seem to result from an older kernel used by Patchbox OS, I wanted to try my luck by installing Modep on a newer Raspberry Pi OS. However, when following
sudo apt install modep

It returns with “Unable to locate package modep”

Has the package been removed or placed elsewhere?

Thank you.

The full command is curl | sh.

Thank you @Griedrius.
I suppose that’s what you get when you know little and try to get by with copying some code from random places… :wink:
adding | sh made all the difference, but you knew that already.

I tried Patchbox OS but it didn’t work with my Behringer UMC204HD USN Audio/MIDI interface, unfortunately. I found out that it has to do with the kernel used in Patchbox OS. According to info on the internet, I found that it should work with kernels later than 5.18.xx That’s why I tried installing Raspberry Pi OS. In the latest version the interface works by adding some quircks.

As I don’t know much about it and all troubleshooting is done by searching the internet for days, I would rather have Patchbox OS.
Is there a version coming with a kernel later than 5.18 or is there a beta version I could try?

I have to make up my mind this afternoon because that’s the latest I could return the interface and get my money back. But then the question remains which USB interface does work well with Linux out of the box.

Thanks again.

Try sudo rpi-update to get the latest Raspberry Pi kernel build, I think it’s 6.+. Keep in mind that these builds are usually experimental and might be unstable. Normal way is to upgrade “raspberrypi-kernel” APT package, the RPi foundation picks a particular known good version as a stable one and publishes it to everyone through their APT server.

Thanks for the help. I have the kernel updated to 6.1.55 and it worked, for a little while. On reboot it functions as it supposed to do, but after a while I got a very distorted output signal. After reboot same issues.

Since today was the last day that I could return the Behringer and get a refund, I stopped hassling about and sent it back.
Maybe I should go the PiSound route, but I opted for a USB Audio/MIDI interface so I could use it for other things with a PC or laptop as well.
If anybody knows of a simple 2x2 USB Audio interface, preferably with MIDI, that works with Raspberry Pi OS and Patchbox OS/Modep without any hassle, please let met know.