Can´t connect Pure Data on RPi

After I disabled the autoconnect from PD to every hardware in my system (by disabling amidiauto) I can not establish any connection from PD on my RPi ZERO with Patchbox OS.

Output from aconnect -l

client 0: 'System' [type=Kernel]
    0 'Timer           '
    1 'Announce        '
	verbunden zu: 128:0, 131:0
client 14: 'Midi Through' [type=Kernel]
    0 'Midi Through Port-0'
client 16: 'Deluge' [type=Kernel,card=0]
    0 'Deluge MIDI 1   '
	verbunden zu: 20:3
	verbunden von: 20:3
    1 'Deluge MIDI 2   '
    2 'Deluge MIDI 3   '
client 20: 'MIDIHUB' [type=Kernel,card=1]
    0 'MIDIHUB MIDI 1  '
	verbunden zu: 28:0
	verbunden von: 28:0
    1 'MIDIHUB MIDI 2  '
	verbunden zu: 24:0, 36:0, 40:0
    2 'MIDIHUB MIDI 3  '
	verbunden von: 28:2
    3 'MIDIHUB MIDI 4  '
	verbunden zu: 16:0
	verbunden von: 16:0
client 24: 'MicroMonsta 2' [type=Kernel,card=2]
    0 'MicroMonsta 2 MIDI 1'
	verbunden von: 20:1, 28:1
client 28: 'NDLR' [type=Kernel,card=3]
    0 'NDLR MIDI 1     '
	verbunden zu: 20:0
	verbunden von: 20:0, 32:0
    1 'NDLR MIDI 2     '
	verbunden zu: 24:0, 36:0, 40:0
    2 'NDLR MIDI 3     '
	verbunden zu: 20:2
    3 'NDLR MIDI 4     '
client 32: 'Vortex Wireless 2' [type=Kernel,card=4]
    0 'Vortex Wireless 2 MIDI 1'
	verbunden zu: 28:0
client 36: 'Vector Synthesizer' [type=Kernel,card=5]
    0 'Vector Synthesizer MIDI 1'
	verbunden von: 20:1, 28:1
client 40: 'HYDRASYNTH DR' [type=Kernel,card=6]
    0 'HYDRASYNTH DR MIDI 1'
	verbunden von: 20:1, 28:1
client 129: 'touchosc' [type=User,pid=339]
    0 'touchosc        '
client 130: 'Pure Data' [type=User,pid=1003]
    0 'Pure Data Midi-In 1'
    1 'Pure Data Midi-Out 1'

Output from amidiminder-rules

hw <---> .app

RtMidiIn Client <-x- *
RtMidiOut Client -x-> *
#131:1 --> Deluge:0
Pure Data Midi-Out 1 --> Deluge:0
Pure Data Midi-In 1 <-- Deluge:0

Vortex Wireless 2 --> NDLR:0 #(Transpose)
Deluge:0 --> MIDIHUB:3

MIDIHUB:0 --> NDLR:0 #(CLOCK)
MIDIHUB:1 --> HYDRASYNTH DR:0
MIDIHUB:1 --> Vector Synthesizer
MIDIHUB:1 --> MicroMonsta 2
MIDIHUB:3 --> Deluge:0

NDLR:0 --> MIDIHUB:0
#NDLR:1 --> Midihub:1 
NDLR:2 --> MIDIHUB:2
#NDLR:3 --> Midihub:3

NDLR:1 --> HYDRASYNTH DR:0
NDLR:1 --> Vector Synthesizer
NDLR:1 --> MicroMonsta 2

Does it work if you make the connection using aconnect or aconnectgui manually?

i have line in /etc/rc.local like this

amidiminder -f /etc/amidiminder.rules -C

sudo systemctl restart amidiminder

works ok

it is also important to remember to have in rc.local

#!/bin/sh
and NOT
#!/bin/sh -e ,this way it will abort if aconnect cannot make connection due to the absent device

bests
K

@Giedrius Manual patching works

@kazeko My /etc/rc.local looks like this

#!/bin/sh
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will “exit 0” on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

# Print the IP address
_IP=$(hostname -I) || true
if [ “$_IP” ]; then

  • printf “My IP address is %s\n” “$_IP”*
    fi

I removed the -e from #!bin/sh than rebooted, restarted amidiminder and still got no connection

insert this two lines at the bottom of rc.local

amidiminder -f /etc/amidiminder.rules -C
sudo systemctl restart amidiminder

I´ve put it not at the end, cause it means behind the exit

#!/bin/sh
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will “exit 0” on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

amidiminder -f /etc/amidiminder.rules -C
sudo systemctl restart amidiminder

# Print the IP address
_IP=$(hostname -I) || true
if [ “$_IP” ]; then

  • printf “My IP address is %s\n” “$_IP”*
    fi

exit 0

does not work, not with reboot nor restart amidiminder :roll_eyes: