Button Assign to Wine / Nord Modular Editor

I’ve followed this superb walkthrough :
…and successfully installed the Nord Modular G1 editor on the Raspbarry Pi + Pi Sound
It runs and seems to recognise the PiSound Midi port - quite a coup !!

BUT when I try and enable the Pisound midi port I get a “Driver Not Enabled” error.
FWIW I also get the same error with a Mio1 USB midi device –
I have tried to find out some more online and the only thing I can find is that the ‘Pulse Sound’ drivers that are favoured by the current Wine installer are inferior to the ‘ALSA’ drivers as only ALSA handles midi.

Now I don’t want to start installing ALSA or some other audio/midi driver for fear of fucking up the Blokas Patchblock OS … I haven’t got a clue about either Raspberry Pi or Linux I’m afraid and so I am stumbling around trying to solve things through googling

Can you shed any light on this ? FWIW I did ‘successfully’ install the Mio windows .exe drivers through the Wine interface (that is the installer ran and completed - I think- but that made no difference…)

The other thing I would like to do (ONCE midi is working - otherwise it’s pointless) is have the PiSound ‘button’ launch the app
The command line to launch the app is ;
wine “/home/patch/Music/nord/Nord Modular Editor v3.03.exe”
I have created the hello_world.sh as per the walkthrough in the Blokas support docs
It triggers the script but doesn’t run the app
I ran the journalctl command mentioned in another post here and the error it returns is ;
error: no drv winediag :nodrv_CreateWindow “The ecplore process failed to start”

The script i have tried is
sudo /usr/local/bin/wine “/home/patch/Music/nortd/Nord Modular Editor v3.03.exe”
… and a few other wild guesses…
Truth is I haven;t got the faintest clue what I am doing and am astonised I have got this far…
testament to the guys walkthrough and the Blokas documentation I think !!

Anyway - can you help please ?

Patchbox OS already has all the drivers necessary to work with MIDI.

It sounds like Wine itself might be missing something (like something disabled in its configuration (including at compile time)) to properly emulate MIDI.

You should try running some other Windows MIDI software (MIDI-OX?) through Wine and see if you can get it to list the MIDI devices.