Bluetooth Connection Error

#1

Hi Guys, I recently installed the app and prepared my raspberry pi 3 for bluetooth pairing. I could’t pair it though the new app to I paired my device through pairing ssh. My phone displays the pisound as a bluetooth device but I can’t get the app to work. Is there anything, that I can do?

In the app it sais: “connection error” “ok”.

Cheers, Thomas

0 Likes

#2

Hey, sometimes it helps to unpair the devices from the bluetooth menu on your mobile device, and then attempt pairing them again.

What do you mean by pairing through ssh?

It should be enough to hold the button down between 3 and 5 seconds (MIDI LEDs blink once a second while held down), release it and the MIDI LEDs should start blinking every 1 second. While they are blinking, the Raspberry Pi is in pairing mode, and in 3 minutes it automatically goes back to normal state, or you can manually turn off discoverability by holding the button again between 3 and 5 seconds.

Once the discoverable mode is on, try connecting to the device via the app, it should initiate pairing.

0 Likes

#3

Hi @Giedrius, I’ve rebaked my SD Card and tried it again. Still no success; is there an complete Image, that I can boot from? I’ve used the MODEP pre-configured Image before, couldn’t get it to work. Can you give me a list of available SD-Images for Rp3 + pisound? Cheers, t.

0 Likes

#4

Hey, at the moment there’s only MODEP image available. The other kind of ‘image’ is flashing Raspbian Lite or Raspbian Desktop, and running the install-pisound.sh from blokas.io.

When having connection issues, unpairing and pairing the devices helps, especially if the OS was reinstalled, as each time some private keys for communication are regenerated, so the old pairing is invalid.

You may use sudo bluetoothctl on Raspberry Pi to access low level bluetooth stuff on the system, there are commands available for listing paired devices, pairing, ‘trusting’, etc… You could try playing around with them, type help for a list of available commands and hopefully the internet has information on what they mean. :slight_smile:

Normally such manual tinkering is not necessary, we haven’t yet find an Android device that would fail to work with Pisound, but we can test only a fairly limited set of them… What is the Android device you are using?

0 Likes

#5

Hey, this might help - I had a similar issue on a freshly baked raspbian. I should also say that I am by no means an expert and the following solution (workaround, shall I say?) was pure blind luck :slight_smile:

What did the trick for me:
After receiving connection error message on your phone, run sudo bluetoothctl on your pi. Your phone should be listed with its BT address and you should also enter some sort of BT console. Then run trust <phone-bt-address>. It should report Changing <phone-bt-address> trust succeeded. After that open the app again and select your raspberry again.

That worked for me, maybe devs will get some ideas what is going wrong here as well.

good luck :slight_smile:

0 Likes