[Beta] MODEP 2018-08-31


#1

Hi guys, we have built a new version of MODEP, at the moment we consider it a beta version, so please test it and let us know how well it works for you, if all goes well, we’ll promote this build to release version.

Download link: http://www.mediafire.com/file/50kcw3h7td8jynx/image_2018-08-31-MODEP.zip/file

Usage notes:

  • User modep, pass blokaslabs (same pass for MODEP hotspot, on by default)
  • Hold The Button for 1-2 seconds to toggle Bluetooth discoverability for connecting with the Pisound App
  • Use 172.24.1.1 IP for TouchOSC clients and connect to MODEP WiFi hotspot

Overview of the changes:

  • Pisound App can now be used to switch pedalboards
  • touchosc2midi integrated by default - connect to MODEP WiFi hotspot and use 172.24.1.1 IP as the destination in TouchOSC compatible software.
  • Realtime kernel
  • OS and MOD DUO updated to latest version available

Detailed changelog:

  • Latest Raspbian Lite packages as of 2018.08.31
  • mod-ui updated from 2017.03.28 to 2018.05.29 (changelog)
  • mod-host updated from 2017.04.11 to 2017.09.05 (changelog)
  • touchosc2midi integrated and enabled by default
  • Pisound hotspot name renamed to MODEP
  • Realtime Linux kernel integrated, v4.14.59-rt37
  • Added MODEP scripts for Pisound App
  • System log rotation made more frequent to avoid running out of disk space when running for long periods of time without rebooting
  • Use performance CPU scaling governor by default

Help with Modep and TouchOSC
Possible to cycle through more than 8 presets with the button?
[Release] MODEP 2018-09-11
#2

I installed it but had some problems because I could not find my power supply and the only one I had was underpowered. Just got a new one and will be testing this weekend, I will leave some comments here as soon as I have done so.

The pisound app support looks awesome!


#3

Just noticed that there is a conflict between the pisound-hotspot service and the dnsmasq service because the hotspot starts a separate dnsmasq. It causes the dnsmasq service to fail without further problems, but to be safe, it would be wise to disable the dnsmasq service in the image. I did it manually on my pi and it works fine. It also help that systemctl status will not show a degraded state.


#4

I found an interesting bug that I am able to reproduce 100% of the time, but I am not sure how to debug further. Here are the steps to reproduce:

  1. Create a new pedalboard
  2. Disconnect left and right channels
  3. In the Simulator category, add a CAPS Cabinet IV
  4. Connect the Cabinet IV output to both outputs
  5. Connect the Inputs to the Cabinet IV input
  6. Validate that you get sound
  7. From the simulator category, add a CAPS AmpVTS
  8. Connect the output of the AmpVTS to the input of the Cabinet IV
  9. Sound stops
  10. Delete the AmpVTS
  11. Still no sound, turning the Cabinet off makes the sound work, but the plugin does not work anymore. The only way I found for the plugin to work again is to delete it and put it back again.

I am not sure if this behaviour occured on the older version of the image, but I never noticed it myself.

The culprit seems to be the AmpVTS, if I try other effects instead of the Cabinet IV, I get the same issue. The AmpVTS alone also does not make any sound.


#5

Caps plugins don’t work for me too.
First : - They can’t work upper than 48kHz (written in the caps internet site).
and : - They compile on debian but some of them don’t work.
also : - there is a problem with the plug in itself and we (under librazik team / trebmuh / sub26nico / jp Cima) have a solution and the creator is informed of the patch to apply.


#6

The CAPS Cabinet IV works for me however, it just stops working as soon as I connect it to CAPS AmpVTS and needs to be reset.

It is not only the CAPS Cabinet IV that stops working, all other plugins I have tested from other sources also stop working once connected to CAPS AmpVTS.

Do you have a link to the patch? Maybe I can test it on my side.


[Release] MODEP 2018-09-11
#7

C* AmpVTS (Ladspa et lv2)
C* Compress (Ladspa et lv2)
C* CompressX2 (Ladspa et lv2)
C* Saturate (Ladspa et lv2)
Don’t work.

See JPCIMA message under :slight_smile:


#8

Using this patch broke Cabinet IV on my side. I get the following error:

mod-host: /usr/include/boost/math/special_functions/detail/bessel_i0.hpp:105: T boost::math::detail::bessel_i0(T) [with T = long double]: Assertion `x >= 0’ failed.

EDIT: The fix seems to be available here: https://github.com/jpcima/caps-lv2/commit/57f122a5e224114380a010178d9100b34e9b68f6 but it is not currently on the master branch. I will recompile and test again.

EDIT 2: Adding the second commit compiles properly and fixes the bugs for me.


#9

Hello, I’m the patch author for the fix of caps plugins.
Please take the version from the PR 14, and not another outdated version which I have created in haste.
As patch file: https://github.com/moddevices/caps-lv2/pull/14.diff

I’ve sent this to Tim Goetze, he has answered me he will either integrate it, or get rid altogether of the faulty Kaiser window code in coming releases.


#10

Thanks to Tim Goetze and jpcima, there is a new release of CAPS plugins.
https://lists.linuxaudio.org/archives/linux-audio-dev/2018-October/037359.html
we have to wait for a new version of CAPS-LV2 version now.
@Giedrius : when CAPS-LV2 is updated, I will send a new message here.
(excuse my poor english please :slight_smile: )


#11

Hello there !

@Giedrius @Ghislain_Bourgeois @jpcima

I have updated the caps plugins for ‘caps-lv2’ and the modguis interfaces at 0.9.26 (latest) version of caps plugins.

I need someone to test on the Pi + Pisound + modep.

Available here : https://github.com/jujudusud/caps-lv2/tree/0.9.26

I can pull request it into Blokaslabs/caps-lv2 if necessary or needed … or whateverelse …
Please tell me !


#12

Hey! A pull request would be great!


#13

Thanks for the reply ! :slight_smile:
the PR is here : https://github.com/BlokasLabs/caps-lv2/pull/2
:slight_smile:


#14

Hey @jujudusud, I’ve just tried out the pull request - all of the CAPs plugins worked fine. I have added a couple of comments in the PR.

Is the pull request ready to be merged?


#15

Hello @Giedrius,
I will check your comments soon. Thanks for your help !


#16

Ok ! It’s now ready to be merged ! :slight_smile: