Behringer UCA 202 poor performance / latency

Hi there, I gave Patchbox OS on a Raspberry 3 B+ a try, using a Behringer UCA 202 USB audio interface. While on standard Raspbian distribution I was able to get decent latency (Buffer 256/periods 2/ 44.1kHz), I wasn’t able on Patchbox OS. I tried different sample rates, frames/period up to 1024 / 8, 12, 16 periods so latency became unusable low and even though had massive crackles in audio rate area (sounds like there is a “distortion layer” over the original sound). I tried qsynth with the default GM SF2 library that is prooved to run smoothly on the used hardware. Sometimes the crackels dissapear to re-appear seconds later, no CPU peaks or other trigger events could be identified. Anyone experienced similar problems? Cheers, Synthfluencer

1 Like

Patchbox uses Jack as the backend. You could try disabling it by closing all audio software and running sudo systemctl stop jack, then launch qsynth, configure it to use ALSA directly, and see if it’s better.

I’ve noticed the same with UMC202.

With JACKD I’ve set
-r 96000
-p 123
-n 3
Which worked great.

Be sure to have RPi connected to original RPi power adapter that supplies at least 2.5A!
If I connect such RPi with those settings and UMC202 to the let’s say some sort of high-end powerbank it won’t work! Even when powerbank says that it supplies 2.5A or even 3A I get crackles and distorted sound!

Problem is that UMC202 is powered from RPi so RPi needs more amperage.

Have a try and let me know!

1 Like

worked great. Thanks for the magic settings! Weird that a higher rate would work better (you’d think it would be more demanding). I can only suppose that the higher-resolution helps stop things from slipping out of phase which would explain the periodic nature of the interference. Like a ‘moire pattern’ emerging into the normal operation, then phasing out again until next time… (I don’t really know what’s going on though).

1 Like

-p 123 or -p 128 ???