Audioinjector Stereo card not working

I am trying to set up my new AudioInjector Stereo card, but I’m having issues. I have set up the card in config.txt but jack refuses to connect:

patch@patchbox:~ $ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: audioinjectorpi [audioinjector-pi-soundcard], device 0: AudioInjector audio wm8731-hifi-0 []
  Subdevices: 0/1
  Subdevice #0: subdevice #0

patch@patchbox:/etc $ cat jackdrc
# exec is used to 'morph' the shell interpreter process into jackd process, saving some system resources.
exec /usr/bin/jackd -t 2000 -R -P 95 -d alsa -d hw:audioinjectorpi -r 48000 -p 128 -n 2 -X seq -s -S

I tried a few different jack settings, nothing works. Every setting I try fails when restarting Jack.

aplay test.wav just hangs.

Any ideas? Does anyone else have this card running?

Try checking the Jack log using sudo journalctl -u jack, as well as see dmesg for any errors and warnings.

Higher setting values or period and buffer count should mean more stability. Also give 44100 sampling rate a try.

I tried every jack combination I could think of… it sounds like it may have been a broken card. I will have to try again. Thanks! I will update this thread if I get it working.

1 Like

I got a replacement card, and it worked right away!

1 Like