Audio is slow and glitchy


#1

I’ve tried everything I could see in these responses and I still get the ‘priority 6 scheduling’ error and my audio is terribly glitchy.

Sometimes when I have MIDI and Audio coming in and out of Pd the Pi just freezes (no audio or MIDI, pisound button not responsive).

I have updated everything and currently running on a RPi 3+.


Snd_pcm_delay failed error
#2

Hi, does this happen on a brand new install of Raspbian, or is it happening on an sd card you’ve been using for a while?

What are the highest CPU users reported by top command while the issues are occurring?


#3

This is a fresh install of Raspbian. Got the RPi, and Pisound last week. I’ve tried doing a fresh install on another sd card and it acts in the same manner. The ‘priority 6 scheduling failed’ error persists.

I am unsure of how I would be able to run the top command since the RPi freezes very unexpectedly.


#4

Hi, I have set up Raspbian Stretch with Desktop 2018-10-09, ran:

  1. curl https://blokas.io/pisound/install.sh | sh to setup Pisound software
  2. sudo pisound-config, installed Pure Data from additional software
  3. sudo raspi-config to enable VNC in interfacing options

Connected via VNC, started a terminal window (so that the launch scripts detect the X display and PD window will pop up when launched), started the MiniMoog patch via the app (or you can run:

cd /usr/local/puredata-patches/MiniMoog/ && /usr/local/pisound-ctl/puredata/puredata_launch.sh minimoog.pd

to launch manually), played around with the keyboard in the app, the sound was just fine, no audio or scheduling errors were reported.

So the conclusion would be that this is not a software issue, it might be a problem in Raspberry Pi itself, the SD card, the power supply (if it’s insufficient, RPi may be unstable, ), or something else specific to your situation. Pisound is unlikely to cause this issue, as the execution is driven by Raspberry Pi.

Could you check the kernel log to see whether there’s any meaningful errors reported by running:

dmesg

?

You may paste the contents here as well for us to take a look.


#5

Hey again, after running dmesg these are the errors I get:

I assume the Under-voltage detected! error means that my power supply isn’t good enough?
I am currently using a USB wall adapter from Mean Well, model number: GS05E-USB and it is supposed to supply 5V 1A.

The rest of the errors I unfortunately don’t understand yet.

Thanks for the assistance.

[ 0.687073] vc_vchi_sm_init: failed to open VCHI service (-1)
[ 0.687082] [vc_sm_connected_init]: failed to initialize shared memory service

[ 2.071679] Under-voltage detected! (0x00050005)

[ 3.953833] brcmfmac: brcmf_fw_map_chip_to_name: using brcm/brcmfmac43455-sdio.bin for chip 0x004345(17221) rev 0x000006

[ 4.238221] brcmfmac: brcmf_c_preinit_dcmds: Firmware version = wl0: Feb 27 2018 03:15:32 version 7.45.154 (r684107 CY) FWID 01-4fbe0b04
[ 4.238886] brcmfmac: brcmf_c_preinit_dcmds: CLM version = API: 12.2 Data: 9.10.105 Compiler: 1.29.4 ClmImport: 1.36.3 Creation: 2018-03-09 18:56:28


#6

1A is way to low. 2.5A power supply is recommended. :slight_smile: The official Raspberry Pi adapter is a good option - https://www.raspberrypi.org/products/raspberry-pi-universal-power-supply/


#7

It seems like the official Raspberry Pi adapter supplies 5.1V while most other adapters supply 5V. How essential is this or is just to ensure that the voltage regulator gets at least 5V? I am looking at my options locally and could only find a 5V 3A adapter. The official adapter will have to be imported.


#8

5V should be enough. :wink:


#9

So I have tried a better power supply and I still get all of the errors I listed in my previous post. I have also tried doing it with two different SD cards both with the latest OS and followed all the procedures outlined in your guide.

I also tried running th RPi without the pisound and it gave me the same errors om two different RPis.

I am going to measure the output of the power supply later and perhaps try one other power supply option as well.

Will post the results here soon. Seems that the Pi is very sensitive when it comes to power.


#10

I do get undervoltage error in dmesg myself sometimes, usually on booting the board. If it does not reoccur often, then it should not be a big problem.

Could you describe the things you are doing exactly, so we can try and reproduce the issue you’re having ourselves?

Additionally, it’d be great if you could get the dmesg log as close to the moment when the issue occurs and share its entire contents with us. (either paste in your reply or via https://pastebin.com/)


#11

So I’ve done some testing on my new power supply and it delivers only 4.8V when measured at the USB port. I went and bought yet another power supply specifically marketed for the RPi and all seems well now.

I still got the scheduling error when starting up PD but after clearing the console and loading up a new patch it didn’t come up again. I’ve been running a patch for a couple of hours how to see if anything goes wrong and all seems stable.

Thanks for the feedback and advice.