Audacity and Jack - recording input level

#1

Sorry if this is a too obvious question, but cant get my head around it.
Im using Patchbox and Audacity, trying to record something.
Is it it not possible to adjust the INPUT LEVEL of the Jack Input in the system?
In Audacity the Input level gain is also grayed out.
Alternatively, I tried this as stated elsewhere:

arecord -D hw:pisound -c 2 -r 48000 -f S16_LE | tee recording.wav | aplay -D hw:pisound

but it always gives me back:
aplay: main:788: audio open error: Device or resource busy
arecord: main:788: audio open error: Device or resource busy

Thanks for any hint!
m.

0 Likes

#2

Hey, the input gain and output volume on Pisound are entirely analog and should be controlled using the two respective potentiometers on the board.

Software loudness level adjustment is possible in software, most likely some plugin has to be placed in the chain on Jack backend (but Audacity does not integrate well with Jack backend at the moment, as it keeps creating and deleting Jack clients every time you start and stop recording). If the input signal is already clipping, software control won’t be able to do anything about it.

This is because the aplay and arecord are using the ALSA backend, while Pisound is already ‘taken’ by the Jack backend running in the background. Only one audio software or backend can be using audio cards in Linux, so before switching the software, you have to close whatever is using the audio card at the moment.

In Jack’s case, you should manually close all audio software, then execute:

sudo systemctl stop jack

Then you should be able to run other programs, or reconfigure Audacity to use ALSA, in that case I think it has usable software volume controls.

0 Likes

#3

Thats a pity that the Input Signal is not controllable, because some inputs dont have Volume control…
I solved it now using an analog Pre-amp where I can control the volume which goes in to Pi.

Thanks for the answer on aplay, will try that out!

0 Likes

#4

You can control it using the ‘gain’ potentiometer on Pisound.

0 Likes

#5

Yes I understand its only Analog controllable, but that wasnt low enough in my case :slight_smile:
anyway thanks!

1 Like

#6

Sorry to come back at this:
I still have the same issue with “Device busy”,
I should have write what I put in the Terminal, was this:
arecord -D hw:pisound -c 2 -r 48000 -f S16_LE | tee recording.wav | aplay -D hw:pisound -

Nothing is open, Im in the Terminal mode, Audacity is closed and I stopped Jack and restarted it again.
I had the ORAC module on, but also taking it off didnt change it.

0 Likes

#7

Hi,
Im using a Rasperry Pi 3B+ with the current Patchbox version.
If jackd daemon is running the arecord and aplay are not capable to run.
They are written to run with ALSA and not with jack.
To record with jack you can use the simple qjackrcd.
See also “Simple Recorders”, and “Media Players” at http://www.jackaudio.org/applications/.
Remember also the presence of Pulseaudio together wit jackd, if you need to disable it follow
https://kodi.wiki/view/PulseAudio/HOW-TO:Disable_PulseAudio_and_use_ALSA(without_removing_PulseAudio)_for_Ubuntu

Lorenzo

0 Likes