Arturia MiniLab mk II with Patchbox (or Linux in general)

Hi all,

I’ve been using the MiniLab mk II primarily with PiSound/RPi 3B+/Patchbox/MODEP, as well as a few other Linux images like SamplerBox, for several months now and haven’t been able to quell an occasional issue present in any MiniLab/Linux combination–“stuck” midi notes/missed midi-off messages. There are forum posts talking about this issue with some Arturia midi controllers, Linux-based systems, and specifically midi-over-USB. Some people have been able to resolve the issue by switching to din midi, but the MiniLab only has the USB option. Some in these forums also found a solution waiting out a firmware update from Arturia. I’m running the latest Arturia firmware on the MiniLab, and the latest stable image of Patchbox/MODEP.

I’ve added an Arturia BeatStep to the mix in the last few weeks and have not had any issue with that controller so far. They’re both being recognized by amidi -l (I’m learning, but am still pretty rudimentary around the cli). I also just reached out to Arturia support, and they reiterated that they don’t support Linux, but to try using a powered USB 2.0 hub (which I’ve tried) among some other BIOS solutions to mimic USB 2.0 on newer ports.

I really like the small format on the MiniLab, with 16 knobs and pads for interfacing with MODEP and the like, but this issue makes performance with the MiniLab too much a gamble. I’m not against upgrading the gear in the near future, but nothing I’ve found so far has matched the size/parameter controls I’m looking for, and how cool would it be for there to be a Linux-based solution to this issue. I’m happy to provide more info and test things out.

Thanks for reading and for all the great work happening in this community!

Hey, one thing to check is to see if there’s any errors reported in the kernel log, close to the moments when issues appear. Once something incorrect occurs, try running:


Or you may do this to be able to scroll up and down in the terminal:

dmesg | less

# Press 'q' to exit afterwards, '/' can be used for substring search

Or just save it to file:

dmesg > dmesg.log

You may run it once after boot up to see what regular messages are expected there. Any errors would appear at the very bottom.

This may provide you with some leads, but depending on where the root cause is, it may not even log anything of interest at all, still worth to check though. :slight_smile:

1 Like

Cool, thanks for the reply and suggestions! :slight_smile: I ran dmesg after boot and scanned through the messages to familiarize myself, but there weren’t any different entries that I could tell when I ran it after (and once during) a stuck-note event. And I didn’t notice any other messages that seemed of potential concern.

I’m able to “un-stick” the note if I press the same key/midi-note again, or just turn the plug-in off and on again. It also typically seems to happen when I’m doing more polyphony or fast lines, but has happened with simpler mono lines as well. MODEP/Patchbox continue to work normally after un-sticking the note.

Any other logs you think might catch a cause for this event?

Correction: the BeatStep also has the same issue, both with midi-over-USB and 5-pin din into the PiSound.

Are you using MODEP only for sound generation? Do the stuck notes occur with any other audio software that can produce sounds for MIDI notes?

Yes, occasionally using other devices for sound generation. Both Arturia devices haven’t had any stuck-note issues when used with iPad softsynths like Synth One or the Moog apps. Also no issues into my MacBook using Analog Lab.

So iOS and Mac based sound generators have no issues, but other software than MODEP on Linux get stuck notes?

Yep, I’ve only gotten the stuck notes with Linux-based sound generators, and have only used the PiSound for that so far. It also happens in ORAC, but in that case the note doesn’t release on repeat–I have to play a low-velocity repeated note for it to be nearly inaudible. I’ve gotten stuck notes using this fork of SamplerBox through the PiSound as well.

I haven’t used any other Linux sound generators yet, but I can try spinning something like LMMS up on Ubuntu and try some lv2’s in there.