Arpeggiator not working as expected

Ok, I have reproduced the issue, indeed it doesn’t work on other channels than 1. :slight_smile:

We’ll get it fixed!

1 Like

Ok, fixed it, get the new firmware containing the fix here: [Download] Midihub Firmware 1.11.2. Let us know how it goes. :slight_smile:

Hi there

Thanks for the super quick response to the problem. The Arpeggiator seems to work fine on all channels now, and the Random option also works fine. Still one more issue. I put an LFO in, to control the Cutoff on my Arturia Microfreak, and all the wafeforms work fine on Channel 1, but again the LFO doesn’t work at all on any of the other MIDI channels.

I hope this one problem as quick to fix as the arpeggiator one. Sorry to keep finding these issues!!



No worries, we’re happy you’re finding and reporting issues we’ve missed. :slight_smile: It’s a lot of functionality and cases to cover.

Please create a dedicated topic for the LFO issue with steps how to reproduce and share the .mhp file you’re using.

1 Like

Sorry if this is a silly question but I am still having issues with the arp. My issue is more related to timing. The arp does not consistently trigger when I hit a key and when it does, it does not always start on the first note of whichever arp mode its on (in the preset below its down). I tried triggering the clock to restart on each key I intend on pressing by mapping the clock on/off to the key but it still does not work as reliably as I would like. Thanks for the help and the great product.

Arp - Issue.mhp (198 Bytes)

Here is a screenshot of the resulting midi. Note that I had to edit the pipes a bit from what I uploaded in order to get the midi to come through from the Arp and Chord.

Hey, the notes are played on the quantization grid, if it happens that the playing position is already after the next beat, it will miss the first note, so the notes should be played slightly ahead of time.

We’ve received a good suggestion for playing the notes anyway as soon as they are played, and to correct the positioning along the way, until it fits the grid again. Once we do that, there shouldn’t be first missing note anymore.

Could the ‘note out of time’ situation be caused by swing parameter?

1 Like

Thanks. I’ll give that a try. Is there a sequence of pipes I can use to “quantize” my input to the clock?

I just tried it after receiving my MIDI Hub today. I can only get up and random to work. Everything else is just up. I also just upgraded the firmware. I’m on 1.11.4

There is a newer Firmware and Editor, please I suggest upgrade.

Thanks, I’ll check it out tomorrow.

OK, I’m still having the same problem, so maybe it is my misunderstanding of how this works. The only way I can get it to go down is to select a negative octave range. It doesn’t matter whether I select up or down at that point as it always goes down if I select a negative range and up if I set a positive range.

So maybe I’m missing something? Random seems to work.
Midihub 2020.07.24 07.58.55 (Preset 1).mhp (115 Bytes)

We’ll check it out. By the way, it might be a good idea to put a Filter pipe after FROM USB A pipe, to keep only ‘Note On’ and ‘Note Off’ messages, just in case there’s any interfering messages coming in from that input.

Yes, I will filter other uninteresting incoming messages. Still new to this so thanks for the reminder!

I just tried your preset, and it seems to work fine, also with Octave Range set to 0. Are you pushing down more than a single note? If not, it would just repeat the same note over and over, without any movement.

1 Like

Well of course with single octave it just plays one note.
When +1 Octaves it alternates between two notes, hard to tell in which direction but with re-trigger note it starts at base note.
With +2 octaves it starts at pressed note, goes up one, goes up another then goes back to starting. It doesn’t matter if I have it set to Up or Down
With -2 it starts at pressed not, goes down one, goes down another and then goes back to starting. It doesn’t matter if I have it set to Up or Down.

Maybe my confusion is what it does when only playing one note. With more than one note it seems quite different and probably is right.

It plays the arpeggio pattern (based on the currently held notes, the more notes that are held, the longer is the pattern. If a single note is held, the pattern itself is just 1 note) first in the current octave the notes are in, then if the octave range is positive, it jumps to the next octave up and plays the pattern again, until it reaches the limit, and starts at the octave the notes are in again. If negative, then pretty much the same, but goes down an octave each time.

1 Like

Got it. My bad, forgot exactly how an arpeggiator works. Working fine!

1 Like

Cheers! :slight_smile: The Arp pipe can be nicely combined with harmonizer and/or sustain pipes. :wink:

Yes, I noticed. Nice tool!

1 Like