Anyone on Liine Lemur and Pisound?

#1

Want to do a wireless connection from my Android to Pisound to talk to hardware synth through midi out/in.
Android can`t find the hotspot. Need help. Working with Liine Lemur.

0 Likes

#2

@Ziggy have activated the Pisound hotspot? Does any other device is able to see the hotspot?
See triple clicking the button here - https://blokas.io/pisound/docs/the-button/

0 Likes

#3

Take a look at this post - Pisound Triple-Click WiFi!, it resolved an issue with WiFi previously, let us know if it helps!

0 Likes

#4

Hotspot is now running since yesterday. There was something wrong with the setup with my Wifi router and the raspberry.
They started to “fight” and the raspberry midi hotspot always lost. Now it is working and next thing for this evening
is to check the routing with aconnectgui. Hope that also usb tethering is supported. The Problem with old Android
systems was that usb-midi interfaces where not supported by liine lemur. There was a small box on the market
called the missing link, but this is no more avaiable. If pisound is doing the same it would be nice. So when some
people say pisound is expensive they are wrong. The missing link was 150$ just for the midi hotspot and for
the same price you have with a rasbberry and pisound hardware-midi in and out and ADC and DAC on board.
Next maybe pisound pro with XLR in and out and small monitor support to build 19" studio equipment?

0 Likes

#5

aconnectgui is now on my raspberry. But what is what and how to connect? There are 2 ports
called pisound MIDI PS and I think these are the 2 5pin midi in out. but where is the wifi midi
coming in translated by osc so that I can connect wifi midi in to hardware port out and vice versa?
USB midi? nothing to see on aconnectgui and an unstable program where you don know where to hit or to click.

0 Likes

#6

and what does it mean “midi through” and timer and annouce?

0 Likes

#7

have installed carla and tried to install Win VSTs. Nothing working. Some pages on the net say you need wine,
some say it is included in carla and when you try to download and install something links are dead or packages somewhere else or not avaiable. Everything a little bit frustrating. Target No. 2 for me would be to have some Win VSTIs in a small box ready for stage.

0 Likes

#8

Did you install the TouchOSC2MIDI using sudo pisound-config? Its ports should appear in aconnectgui when the WiFi hotspot is enabled.

These are built-in ports by ALSA. The MIDI through simply echoes whatever comes into the INPUT to the OUTPUT virtual port. Some info on the other ports: https://askubuntu.com/questions/633542/what-are-the-timer-and-announce-ports-of-alsas-system-midi-client-and-how-to-us

I haven’t seen a need to use them yet though.

Windows VSTs are most likely built for the x86 processor architecture. It’d be very inefficient to run them on Raspberry Pi. It’s better to look into the lv2 plugins.

0 Likes

#9

trying to install touchosc2midi. Seems that the installer in the console is runnig in circles.
running setup.py bdist_wheel for cython started
running setup.py bdist_wheel for cython still running
5x is it normal?

0 Likes

#10

ok, now running. Takes a looong time to install.

0 Likes

#11

Ok now. After reboot aconnectgui is showing up more ports. now I have to find out what is what.
thank you very much up to this point.

0 Likes

#12

hello, I’m connect touchOSC to the pi, and am having trouble. I’ve made the hotspot, and I installed TouchOSC2MIDI. Still not getting OSC into a Pd patch.

When I enter “cd aconnect-gui” or just “aconnect-gui” in the terminal, it tells me that these things are not recognized

Any help would be greatly appreciated!

0 Likes

#13

aconnect-gui does not seem to be a command. aconnect -I or aconnect -o shows midi ports, but TouchOSC2MIDI is not listed.

Additionally, on my phone, I can see “pisound” listed in the wifi networks, but I have not succeeded in connecting to it. I thought I was, but it has not succeeded at doing that

0 Likes

#14

touchosc2midi runs only when the WiFi hotspot is successfully running. See MODEP, Pisound, WiFi, and You for some pointers on how to get it fixed.

Btw, the command is aconnectgui, my post above in this thread had a typo.

0 Likes

#15

Thanks Giedrius, I’ll start going through that in an hour and let you know. Can you help me with this other related issue? When I was working on this, I downloaded touchOSC2midi through the pisound-config, and it made it so that my rPi would no longer automatically get on my internet at home, which made things quite difficult. I ended up going back to the backup I made on a separate SD. I’m worried that I won’t be able to resolve this issue, which will make it so that I can’t VNC into my pi without a tv, keyboard, and mouse. Is there a way to download touchosc2midi and not make it reconfigure the way wifi is otherwise set up?

Dr. Thomas Echols
Classical Guitarist

www.thomasechols.com

Composer, Songwriter

www.manwomanfriendcomputer.com

Listen to Plainte Calme on iTunes and

Man, Woman, Friend, Computer on Bandcamp

0 Likes

#16

also, I’ve been running the newest pisound button v 1.10 which should resolve this, yes?

Thanks,

Tom

0 Likes

#17

Ok it looks like I have the hotspot running after updating and upgrading. the aconnectgui is still an unrecognized command in the terminal. Any thoughts on why this is?

thanks!

0 Likes