Will Midihub support MPE controllers as inputs?

I am currently using a Roli Seaboard Block to control an Audiothingies MicroMonsta. I am using a Kenton USB MIDI host to provide a 5 pin MIDI out from the Seaboard. I am hoping to be able to pass MPE data through the Midihub and be able to take advantage of some of the tools (such as merging and filtering) on the way to the MicroMonsta. Will this work?

The MPE data consists of regular MIDI CC messages, so it should work with Midihub and its pipes.

1 Like

Would midi keyboard -> microtonal mapping using Midihub -> MPE-capable synth also work?

The Microtonal Scale Remap pipe produces each new note on a new MIDI channel, with the appropriate Pitch Bend message on that channel. If the MPE synths work fine with that, then it’s all good. :slight_smile:

3 Likes

@trondolsen I just tried a Preset using an AKAI LPK25 into a ContinuuMini works nicely :wink:

4 Likes

Great! since I´ve already put in an order earlier today :slight_smile:

Now got me thinking what…

are you planing on using? I might do some more testing :wink:

I enjoy using tuning in softsynths so it would be great to have this options for hardware synth too. Since I have an additional piano keyboard available it would be exciting to try this out.

1 Like

Ok! I’ll connect MH to Gig Performer (my plugin host of choice) and use, for example Pigments, Aalto, Quanta… all support MPE; I’ll try to record something.

3 Likes

Had to order one myself :slight_smile: Arrived just 4 days after shipping internationally!

The microtonal scale worked like a charm between my keyboard and U-HE Repro 5 softsynth. Keyboard input works was mapped correctly onto 16 midi channels.

Question to developer: I noticed that Microtonal import errored on .scl files that used numerical values.

! example.scl
!
example
 2
!
 78.26087
 104.34783
2 Likes

Hey, I just placed the contents as you showed here into an .scl file, and it imported ok. Could you attach the .scl file that fails to import directly to the post?

2 Likes

Actually, everything work fine afterall. I had tried to convert some .tun files from Repro til .scl and there were some syntax errors. The converted values also didn’t work :slight_smile:

2 Likes