USB hubs not showing in Mac OS X

I can not get any of the MidiHub USB ports to show up in any of my Mac music applications including Logic, MainStage, Hosting AU and several stand alone apps including Unify. I can see all 4 of the DIN in and out ports on MidiHub in these applications so my keyboard can send notes to my computer apps but can’t get any of Midihub’s cool arp and delay tricks back into my computer via virtual USB ports. Can anyone actually see any of the 4 USB ports in Midihub in any Mac music application? Are we sure that Midihub is advertising the virtual USB ports correctly? I can connect the Midihub editor to the Midihub so I know the USB connection to the computer is working. MidiMonitor only shows MIDI input coming into but shows nothing going out. Am I missing something obvious here? Thanks for your help!

Hi, these are the port names you should see on macOS:

To get data into audio software running on the host pc, you have to use TO USB X output pipes.

Right I’ve been setting it up with “TO USB” ports but it’s not working, the USB port never shows up on the Mac anywhere. I know what I should be seeing but I’m only seeing the Midihub DIN in and out ports which work great but no USB ports show up at all even when the pipe is set up with TO USB outs. I don’t think the USB ports are working on Mac.

What do you mean by you’re seeing only DIN in and out ports?

OK after some digging it appears the 4 in and out ports that I thought were the DIN ports ARE the USB ports so the ports are showing in Mac OS X however I am unable to send any of my pipes in Midihub to those USB ports to trigger the music programs. I have some pipes that have lots of arps and delays but can’t get ANY of them to play through my computer programs so the ports do show up on the computer but I’m not able to trigger anything on the computer from those MH USB out pipes. The pipes will trigger hardware synths from the MH DIN outs if I plug one in but nothing on the USB out pipes will trigger in music apps.

To process messages only within USB domain, you have to use ‘FROM USB X’ and ‘TO USB X’ for input and output.

Can you show the preset you’re currently using?

1 Like

I’ve tried FROM USB TO USB but that doesn’t work either. I can send the pipes but I’ve tried so many and none of them work. Here is the latest try. They are all just combinations of DIN A in pipe (keyboard is plugged in there) to any of the USB outs with a second pipe of From USB to USB and another pipe with DIN to Virtual with a second pipe Virtual IN with Arp , Delay etc to USB out. I can get the keyboard to play in the app with DIN to USB out but I can not get any of the MIDI effects in Midihub to play out of a USB port

Midihub 2020.08.23 15.08.18 (Preset 2).mhp (190 Bytes)

Do you provide the required clock messages to Arp or Delay (if Delay is in synced mode)? (example)

First, try to get something simple to work, like transpose +12 semitones.

1 Like

That was it! It was not realizing that FROM USB needs to be connected directly TO USB that fixed it. I got so sidetracked trying to get the USB working that I forgot to add the clock to the pipe to get the arp to work (User error, I should have known better because I already knew about the clock). I don’t think I had read before about the FROM USB TO USB connection needing to be made to work strictly in USB, I’ll remember that in the future. Thanks for your help!!