[solved] Driver install issue


#1

I’ve found a power supply (a cheap Maplins own brand multi adapter :slight_smile: - works a treat). Really easy to put together and seems pretty sturdy.

Pd was already installed so tried to install the drivers using

wget http://blokas.io/pisound/install-pisound.sh
chmod +x install-pisound.sh
./install-pisound.sh

But I get a TLS issue:

pi@raspberrypi:~ $ ./install-pisound.sh
Cloning into 'pisound'...
remote: Counting objects: 24, done.
remote: Total 24 (delta 0), reused 0 (delta 0), pack-reused 24
Unpacking objects: 100% (24/24), done.
Checking connectivity... done.
--2016-10-10 21:00:39--  https://raw.githubusercontent.com/notro/rpi-source/master/rpi-source
Resolving raw.githubusercontent.com (raw.githubusercontent.com)... 62.252.172.241
Connecting to raw.githubusercontent.com (raw.githubusercontent.com)|62.252.172.241|:443... connected.
GnuTLS: A TLS fatal alert has been received.
GnuTLS: received alert [0]: Close notify
Unable to establish SSL connection.
make -C pisound-module 
make[1]: Entering directory '/home/pi/pisound/pisound-module'
make -C /lib/modules/`uname -r`/build M=/home/pi/pisound/pisound-module modules
make[2]: Entering directory '/home/pi/pisound/pisound-module'
make[2]: *** /lib/modules/4.4.13-v7+/build: No such file or directory.  Stop.
make[2]: Leaving directory '/home/pi/pisound/pisound-module'
Makefile:39: recipe for target 'all' failed
make[1]: *** [all] Error 2
make[1]: Leaving directory '/home/pi/pisound/pisound-module'
Makefile:28: recipe for target 'pisound-module' failed
make: *** [pisound-module] Error 2
make -C pisound-module install
make[1]: Entering directory '/home/pi/pisound/pisound-module'
make -C /lib/modules/`uname -r`/build M=/home/pi/pisound/pisound-module modules_install
make[2]: Entering directory '/home/pi/pisound/pisound-module'
make[2]: *** /lib/modules/4.4.13-v7+/build: No such file or directory.  Stop.
make[2]: Leaving directory '/home/pi/pisound/pisound-module'
Makefile:42: recipe for target 'install' failed
make[1]: *** [install] Error 2
make[1]: Leaving directory '/home/pi/pisound/pisound-module'
Makefile:28: recipe for target 'pisound-module' failed
make: *** [pisound-module] Error 2
sudo: ./enable-pisound.sh: command not found
pi@raspberrypi:~ $ 

So some searching on the RPF forums, and I try using curl -L instead of wget

Still an error, but slightly different:

fatal: destination path 'pisound' already exists and is not an empty directory.
--2016-10-10 22:40:02--  https://raw.githubusercontent.com/notro/rpi-source/master/rpi-source
Resolving raw.githubusercontent.com (raw.githubusercontent.com)... 62.252.172.241
Connecting to raw.githubusercontent.com (raw.githubusercontent.com)|62.252.172.241|:443... connected.
GnuTLS: A TLS fatal alert has been received.
GnuTLS: received alert [0]: Close notify
Unable to establish SSL connection.
make -C pisound-module 
make[1]: Entering directory '/home/pi/pisound/pisound-module'
make -C /lib/modules/`uname -r`/build M=/home/pi/pisound/pisound-module modules
make[2]: Entering directory '/home/pi/pisound/pisound-module'
make[2]: *** /lib/modules/4.4.21-v7+/build: No such file or directory.  Stop.
make[2]: Leaving directory '/home/pi/pisound/pisound-module'
Makefile:39: recipe for target 'all' failed
make[1]: *** [all] Error 2
make[1]: Leaving directory '/home/pi/pisound/pisound-module'
Makefile:28: recipe for target 'pisound-module' failed
make: *** [pisound-module] Error 2
make -C pisound-module install
make[1]: Entering directory '/home/pi/pisound/pisound-module'
make -C /lib/modules/`uname -r`/build M=/home/pi/pisound/pisound-module modules_install
make[2]: Entering directory '/home/pi/pisound/pisound-module'
make[2]: *** /lib/modules/4.4.21-v7+/build: No such file or directory.  Stop.
make[2]: Leaving directory '/home/pi/pisound/pisound-module'
Makefile:42: recipe for target 'install' failed
make[1]: *** [install] Error 2
make[1]: Leaving directory '/home/pi/pisound/pisound-module'
Makefile:28: recipe for target 'pisound-module' failed
make: *** [pisound-module] Error 2
sudo: ./enable-pisound.sh: command not found

And that’s where I’m at!

Any advice gratefully received :slight_smile:

Cheers

Dan


#2

Hey,

Thank you for your report, I will try and see how I can improve the install-pisound.sh script.

Please try executing each step as described here: http://wiki.blokas.io/index.php/Step-by-Step_pisound_Installation_Instructions

Let us know how that works out :slight_smile:


#3

Btw, it looks like you’re hitting the same network issue, downloading a file from GitHub.

You may try using some options for wget / curl to ignore the certificate errors (however, I just tried it myself, I didn’t get any certificate issues for GitHub…)

–2016-10-10 22:40:02-- https://raw.githubusercontent.com/notro/rpi-source/master/rpi-source
Resolving raw.githubusercontent.com (raw.githubusercontent.com)… 62.252.172.241
Connecting to raw.githubusercontent.com (raw.githubusercontent.com)|62.252.172.241|:443… connected.
GnuTLS: A TLS fatal alert has been received.
GnuTLS: received alert [0]: Close notify
Unable to establish SSL connection.


#4

Hiya - thanks for getting back to me :slight_smile:

So:

pi@raspberrypi:~ $ git clone https://github.com/BlokasLabs/pisound.git
fatal: destination path 'pisound' already exists and is not an empty directory.
pi@raspberrypi:~ $ sudo wget https://raw.githubusercontent.com/notro/rpi-source/master/rpi-source -o /usr/bin/rpi-source
pi@raspberrypi:~ $ rpi-source -q --tag-update
/usr/bin/rpi-source: line 1: --2016-10-11: command not found
/usr/bin/rpi-source: line 2: syntax error near unexpected token `('
/usr/bin/rpi-source: line 2: `Resolving raw.githubusercontent.com (raw.githubusercontent.com)... 62.252.172.241'

I had a folder in /home/pi called pisound so I’m guessing I’d cloned the repo? I deleted that folder and followed the instructions at http://wiki.blokas.io/index.php/Step-by-Step_pisound_Installation_Instructions

Still having problems, here’s the output:

pi@raspberrypi:~ $ sudo wget https://raw.githubusercontent.com/notro/rpi-source/master/rpi-source -O /usr/bin/rpi-source
--2016-10-11 09:32:08--  https://raw.githubusercontent.com/notro/rpi-source/master/rpi-source
Resolving raw.githubusercontent.com (raw.githubusercontent.com)... 62.252.172.241
Connecting to raw.githubusercontent.com (raw.githubusercontent.com)|62.252.172.241|:443... connected.
GnuTLS: A TLS fatal alert has been received.
GnuTLS: received alert [0]: Close notify
Unable to establish SSL connection.
pi@raspberrypi:~ $ sudo curl -L https://raw.githubusercontent.com/notro/rpi-source/master/rpi-source -O /usr/bin/rpi-source
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 12670  100 12670    0     0  31855      0 --:--:-- --:--:-- --:--:-- 31914
curl: (3) <url> malformed
pi@raspberrypi:~ $ sudo chmod +x /usr/bin/rpi-source
pi@raspberrypi:~ $ rpi-source -q --tag-update
pi@raspberrypi:~ $ rpi-source
pi@raspberrypi:~ $ cd pisound
pi@raspberrypi:~/pisound $ make
make -C pisound-module 
make[1]: Entering directory '/home/pi/pisound/pisound-module'
make -C /lib/modules/`uname -r`/build M=/home/pi/pisound/pisound-module modules
make[2]: Entering directory '/home/pi/pisound/pisound-module'
make[2]: *** /lib/modules/4.4.21-v7+/build: No such file or directory.  Stop.
make[2]: Leaving directory '/home/pi/pisound/pisound-module'
Makefile:39: recipe for target 'all' failed
make[1]: *** [all] Error 2
make[1]: Leaving directory '/home/pi/pisound/pisound-module'
Makefile:28: recipe for target 'pisound-module' failed
make: *** [pisound-module] Error 2
pi@raspberrypi:~/pisound $ sudo make install
make -C pisound-module install
make[1]: Entering directory '/home/pi/pisound/pisound-module'
make -C /lib/modules/`uname -r`/build M=/home/pi/pisound/pisound-module modules_install
make[2]: Entering directory '/home/pi/pisound/pisound-module'
make[2]: *** /lib/modules/4.4.21-v7+/build: No such file or directory.  Stop.
make[2]: Leaving directory '/home/pi/pisound/pisound-module'
Makefile:42: recipe for target 'install' failed
make[1]: *** [install] Error 2
make[1]: Leaving directory '/home/pi/pisound/pisound-module'
Makefile:28: recipe for target 'pisound-module' failed
make: *** [pisound-module] Error 2
pi@raspberrypi:~/pisound $ sudo ./enable-pisound.sh
sudo: ./enable-pisound.sh: command not found

Replaced wget with curl -L

Cheers

Dan


#5

I don’t like the ‘url malformed’ error :slight_smile:

Based on the errors below, looks like rpi-source didn’t do much… It is the one that’s supposed to get the /lib/modules/version/build folder created.

Did ~/linux folder appear? (also should be done by rpi-source)

Also you can try and look through the rpi-source wiki here: https://github.com/notro/rpi-source/wiki

The result of running rpi-source is to have ~/linux and /lib/modules/4.4.21-v7+/build folders, once those are in place, yo ucan continue with next steps. These folders are required to successfully build the pisound’s linux kernel module on your system.


#6

Hi there … I am having other problems …
this is what I get from the terminal … it seems that the last command is not reaching the enable-pisound.sh

pi@raspberrypi:~ $ sudo wget https://raw.githubusercontent.com/notro/rpi-source/master/rpi-source -O /usr/bin/rpi-source
–2016-10-11 11:51:57-- https://raw.githubusercontent.com/notro/rpi-source/master/rpi-source
Resolving raw.githubusercontent.com (raw.githubusercontent.com)… 151.101.12.133
Connecting to raw.githubusercontent.com (raw.githubusercontent.com)|151.101.12.133|:443… connected.
HTTP request sent, awaiting response… 200 OK
Length: 12670 (12K) [text/plain]
Saving to: ‘/usr/bin/rpi-source’

/usr/bin/rpi-source 100%[=====================>] 12.37K --.-KB/s in 0.001s

2016-10-11 11:51:57 (10.1 MB/s) - ‘/usr/bin/rpi-source’ saved [12670/12670]

pi@raspberrypi:~ $ sudo chmod +x /usr/bin/rpi-source
pi@raspberrypi:~ $ rpi-source -q --tag-update
pi@raspberrypi:~ $ rpi-source

*** gcc version check: OK

*** Using: /usr/share/doc/raspberrypi-bootloader/changelog.Debian.gz

*** Latest firmware revision: ad8608c08b122b2c228dba0ff5070d6e9519faf5

*** Linux source commit: 2d31cd571e6f2ac61a3eda273d973058e1bb1f58

*** Kernel source already installed: /home/pi/linux-2d31cd571e6f2ac61a3eda273d973058e1bb1f58

pi@raspberrypi:~ $ cd pisound
pi@raspberrypi:~/pisound $ make
make -C pisound-module
make[1]: Entering directory ‘/home/pi/pisound/pisound-module’
make -C /lib/modules/uname -r/build M=/home/pi/pisound/pisound-module modules
make[2]: Entering directory ‘/home/pi/linux-2d31cd571e6f2ac61a3eda273d973058e1bb1f58’
Building modules, stage 2.
MODPOST 1 modules
make[2]: Leaving directory ‘/home/pi/linux-2d31cd571e6f2ac61a3eda273d973058e1bb1f58’
make[1]: Leaving directory ‘/home/pi/pisound/pisound-module’
make -C pisound-btn
make[1]: Entering directory ‘/home/pi/pisound/pisound-btn’
make[1]: Nothing to be done for ‘all’.
make[1]: Leaving directory ‘/home/pi/pisound/pisound-btn’
pi@raspberrypi:~/pisound $ sudo make install
make -C pisound-module install
make[1]: Entering directory ‘/home/pi/pisound/pisound-module’
make -C /lib/modules/uname -r/build M=/home/pi/pisound/pisound-module modules_install
make[2]: Entering directory ‘/home/pi/linux-2d31cd571e6f2ac61a3eda273d973058e1bb1f58’
INSTALL /home/pi/pisound/pisound-module/pisound.ko
DEPMOD 4.4.21-v7+
make[2]: Leaving directory ‘/home/pi/linux-2d31cd571e6f2ac61a3eda273d973058e1bb1f58’
‘pisound.dtbo’ -> ‘/boot/overlays/pisound.dtbo’
make[1]: Leaving directory ‘/home/pi/pisound/pisound-module’
make -C pisound-btn install
make[1]: Entering directory ‘/home/pi/pisound/pisound-btn’
Backing up scripts in /usr/local/etc/pisound to /usr/local/etc/pisound/backups/2016-10-11.11:53:06
make[1]: Leaving directory ‘/home/pi/pisound/pisound-btn’
pi@raspberrypi:~/pisound $ sudo enable-pisound.sh
sudo: enable-pisound.sh: command not found
pi@raspberrypi:~/pisound $ sudo ./enable-pisound.sh
sudo: ./enable-pisound.sh: command not found
pi@raspberrypi:~/pisound $

do you have any idea
Ciao Mat


#7

This should do the trick:

chmod +x enable-pisound.sh
sudo ./enable-pisound.sh


#8

Just to let everybody know:

Last two commands that Giedrius postet DID work for me …
no my little beauty is working correctly …
test starting !!
Ciao Mattia


#9

[SOLVED]

OK so there are two things that seemed to solve this one.

First thing is I used a different network to my home wifi, which gave this error:

ERROR:
bc is NOT installed. Needed by 'make modules_prepare'. On Raspbian, run 'sudo apt-get install bc' to install it.

So I installed bc

Then:

pi@raspberrypi:~ $ chmod +x install-pisound.sh

Then:

pi@raspberrypi:~ $ cd pisound
pi@raspberrypi:~/pisound $ chmod +x enable-pisound.sh
pi@raspberrypi:~/pisound $ sudo ./enable-pisound.sh
pi@raspberrypi:~/pisound $

Which worked for me :slight_smile:


#10

4 posts were split to a new topic: Troubles installing pisound / verifying power supply