Routing MODEP outputs to a DAW

Reaper installed, but no jack instance running next. Will look into that Wednesday, then look at adding your script into the mix.

***UPDATE ***

Took a while to get a chance to get my JACK instance sorted, but now it is.
Just needed to adjust to 48k for my USB audio device.
I’ve also git cloned your script and tried running it, and it didn’t generate any errors sothats a good start.

Next time I get a chance I will be seeing it the script does indeed give me channels 3 and 4 in Reaper when I change the settings for it.


Progress! In a way, ha ha.
The alesis interface was atrocious, making a lot of digital noise when putting a guitar through it, so it has been subbed out for a Zoom U-24. Much better for me as it does phantom power so I can do vocals on a condenser mic through it too.
Adjusted the script to map the outs to 5 and 6 of the jack inputs for reaper, and it seems to work nicely. I love it.
I still have a problem with some minor noises like a ‘digital fizz’ that seems to happen every few seconds almost like clockwork, and it seems to be coming from MODEP. If I disconnect the audio in from the out it doesn’t happen, but when it’s routed to the output it happens, regardless of path the audio follows.
If I can iron out that then I’ve got a system I’d be happy to take out as my portable recording rig.
In fact if it works I wouldn’t mind building a second system to act as a multitrack recorder for my Berhringer X18.

1 Like

It might not be the same thing I encountered before, but if you have audio cables going close to the Raspberry Pi near the power connector side, the WiFi signal actually ended up injected into my audio stream. Disabling the WiFi interface fixed the issue. If that turns out to be the case, and you’d prefer keeping the WiFi on, some shielded cables should help avoid the noise.

The command for disabling it I think was sudo ifconfig wlan0 down

1 Like

That’s a really good point, thanks mate!
I am using WiFi at the moment for controlling the modep effects while Reaper is on the Pi’s touchscreen, but I’ll try disabling it and see if that is the cause.
I’ll try changing cables too.

1 Like

So I’m still getting all kinds of funky noise out of this bad boy. I’ve been messing around with the jack settings and Jack seems to be fine, it just keeps generating loads of digital noise and distortion.
Tomorrow I’m going to try putting the Pi with my Behringer X18 desk and seeing if I can have that work with it; while I’m waiting on a new shielded XLR cable to arrive (my current one is old and could be damaged) I have a theory that the Zoom U24 could be putting a strain on the power and causing issues.
It shouldn’t, drawing power from the USB3 port of the Pi, but its worth testing an interface with its own power supply.
Excited to have 16 inputs to play with ha ha!

1 Like

FFS, trued all my shiny new shielded cables and still dodgy.
Changed my JACK settings via patchbox from 2 to 3 for the last value and it fecking worked flawlessly ha ha ha.
I can focus on script to open reaper before routing the inputs and then work on my MODI pedal.

Ordered an expression pedal too, so incan try capturing it via my arduino analog pins.

1 Like