Problems with jack and sooperlooper


First message for me, so I have to congratulate the blokas team for the good work: the pisound is very well done and a great product. I’m an old time linux audio user so it is a super convenient device for me.

One of the main uses I wanted a raspi+pisound box for is for running the excellent sooperlooper looping software. It needs jack and unfortunately doesn’t work with alsa alone, but I get it to work quite well with a period of 128, except that sporadically it “freezes” (for lack of a better word) jack and the audio is abruptly stopped. With greater periods the issue may be postponed but it happens nonetheless.

At this point the only option is to kill both sooperlooper and jackd. I already sent a message to the sooperlooper forum but I think I might also check here…

It seems that it’s when sooperlooper get xruns (the message it starts to emit continuosly is got xrun). I tried with other jack software like yoshimi and I don’t have this behaviour even in case of xruns.

Anyone tried sooperlooper and got the same issue?

Thanks in advance

Hi, how easy is this to reproduce? It’d be great to find the quickest way to get into this bad state, then one could attach to the jack server, preferably built with debug information enabled, using gdb and see where it is stuck.

Quite easy if run with a low frame/period, e.g as root in a vnc session.

/usr/bin/jackd -R -dalsa -dhw:pisound -r48000 -p64 -n2


sooperlooper -q -U osc.udp://localhost:19084/ -p 9951 -l 1 -c 2 -t 240  &


slgui &

the program starts and if you use it it may work for a while until xruns occur, you may stress it by adding loops (sessions -> add stereo loop)

With such a low frame/period should be easy to make it crash

Thanks for your answer and your work

Best regards

Today it happened also with yoshimi… so far jackd is not stable enough to rely on it for live performance. I’m the only one with those problems? apt policy jackd2 says

Installed: 1.9.10+20150825git1ed50c92~dfsg-5
Candidate: 1.9.10+20150825git1ed50c92~dfsg-5
Version table:
*** 1.9.10+20150825git1ed50c92~dfsg-5 500
    500 stretch/main armhf Packages
    100 /var/lib/dpkg/status
 1.9.8~dfsg.4+20120529git007cdc37-5+fixed1~raspbian1 500
    500 wheezy/main armhf Packages

maybe I should try the autostatic version? If I try that a lot of packages (including puredata) would be uninistalled…

One approach would be to try the Autostatic version on another SD card. Been switching back and forth between a full Raspbian Stretch with all sorts of goodies, a stock version of MODEP with a few plugins, and an experimental version of MODEP to try building all sorts of plugins (including SooperLooper). Some dependencies are a bit tricky to handle and installing some packages breaks my MODEP (can’t hear any sound after sudo apt-get install jackd jackd2 libjack-jackd2-0 libopus0 python-dbus python-dbus-dev python-gi qjackctl, for instance). But, in your case, it’d probably allow you to build a very stable setup. pd-vanilla is easy enough to install with Autostatic (sudo apt-get install libjack-jackd2-0 libopus0 libportaudio2 puredata-core). It might break things (just broke my MODEP, for instance). But at least you’d know without compromising your main setup.

3 posts were split to a new topic: MODEP crash when using sooperlooper