MODEP on pisound


#1

MODEP with pisound is so much fun. It works out of the box without any linux knowledge what so ever. Real plug and play. And the sound is wonderful. Is anyone else here having fun with this?

modep on pisound with ‘lushomat’ as pedalboard (This is just a test and not a musical statement. :slight_smile: )


#2

Is it possible to update the prepared MODEP image to include the SooperLooper?


#3

Sorry to hijack the thread with a silly question… but this is getting into the paranoia region of my brain.
I did try to install MODEP onto an existing Raspbian install (not using the image) since I didn’t have a spare SD.
then I had to break off the process because I had to run and had to switch off the computer.
Does the install process put lots of files&configs scattered around the system which I need to hunt down, or is deleting the “modep” folder in my home directory sorting that out?


#4

Nevermind, I’ll make a new SD for Stretch anyway.
In the meantime I’ve burned the MODEP image and have given it a go. I’m amazed! It really works great! The selection of available synth modules is perhaps improvable, but the MDA stuff is pretty decent. I can see myself using this to play live… once I have set up a couple of pedalboards and mapped the MIDI controller that could work really well.
I only need to see how stable the whole thing is. Apart from the live aspect, this is certainly perfect for jamming, or as a general purpose FX unit as well!
I’m liking Pisound more each day.


#5

I have problems using the MODEP web interface on the iPad, I can’t turn any of the knobs and scrolling/zooming is a bit weird. Does that work for you?
Also: how do you set the MIDI channel for the generators? It would be cool if I could put two synths in a pedalboard and have them respond to different channels, right now it seems they all work in OMNI mode.


#6

I tested the MODEP web interface on my iPad too. Everything works except for the rotary knobs.


#7

Not sure that there is a mechanism to specify the channel, but I have used modep with two separate midi keyboard inputs, one via the DIN plug on the pisound and one via a usb connection. You can then select both inputs on the modep midi icon, and you get two input leads. You can assign each one to a different module or string of modules.


#8

yeah that works fine. Every MIDI device has its own virtual plug on the pedalboard. I found that Modep still meses up the order and state of the enabled devices, but that’s another story.


#9

Wonder if any progress has been on this front (getting SooperLooper in MODEP). Do notice that the LV2 version SL and some other neat plugins (like Loopor) are in the MOD Plugin Builder repo. Since SL does build on Raspbian, one might hope that it’s at least possible to add the plugin manually (it did work for me with some of the Zynthian plugins, thanks to @tomerb).
Plugged my Pi into Ethernet, installed the dependencies from that MOD Plugin Builder package’s README.md, and got the bootstrap.sh script started (on my first run, it had issues finding a libtool binary but it sounds like sudo apt-get install libtool-bin solved this, as per this advice). It’s supposed to take a while anyway and it’s time for bed. Will try to report back if some of these things end up working. Would be really cool to have a looper on MODEP.
Might eventually try to build some simple plugins using the examples which already work. The MIDI chord plugin opens up neat opportunities, for me. Would rather not have parallel chords, but maybe it’s possible to tweak that plugin to allow for different chord types to cycle.
Would also love to have some kind of recording plugin, either for the audio or the MIDI messages. Sure, MODEP is specifically not meant to replace a DAW. But it could still be really neat to record some excerpts from our playing.


#10

Ha! Ran out of space on this 16GB SD card. Will try with a bigger card, probably during the weekend.


#11

Hi Enkerli,

i am still trying to get the looper up and running but without success so far. I started to write my own little LV2 plugin (a simple mixer) to better understand how MODEP / LV2 works. But progress is very slow. I am used to work with a OSX / XCODE/ AU dev-environment and thats a lot easier.

A recording plugin is also on my wishlist or for a start a audiofile player to jam with prerecorded loops.


#12

Got MOD’s SooperLooper LV2 plugin running. First went through the whole route of installing SooperLooper itself, which was pretty involved as a process (dependencies which weren’t so easy to figure out from the start). After that worked but there wasn’t any sign of LV2, did a search for SooperLooper LV2 and found the MOD repo. At that point, it was just a matter of doing make;sudo make install and it all worked. Then copied the lv2 to the modep/.lv2 directory, did a reboot, and SooperLooper was found in my plugins, with full GUI. It works flawlessly in my quick tests. Pretty exciting.
Would be nice to get the audio file, somewhere. Maybe SL keeps it, dunno how these things work.


Looper LV2 Plugin for MODEP/Raspbian?
#13

For reference, here’s most of my command-line history from my session installing SooperLooper and then the SooperLooper LV2. Maybe the last part is the only one necessary, and this whole process is clearly not the best way to do things. But it did eventually work. (Hopefully didn’t delete a line which would be required for things to work.
So it’s really not a usable script, but maybe it could help someone?

git clone https://github.com/essej/sooperlooper.git
cd sooperlooper/
./install-sh 
./autogen.sh 
sudo apt-get install libtool-bin
sudo apt-get install autopoint
sudo apt-get install libncurses5-dev libncursesw5-dev 
sudo apt-get install sigc++
sudo apt-get install liblo
sudo apt-get install libsndfile
sudo apt-get install libxml2-dev
sudo apt-get install libwxgtk2.8-dev
wget http://code.breakfastquay.com/attachments/download/34/rubberband-1.8.1.tar.bz2
bunzip2 rubberband-1.8.1.tar.bz2 
tar -xf rubberband-1.8.1.tar 
cd rubberband-1.8.1/
./configure 
wget http://www.mega-nerd.com/SRC/libsamplerate-0.1.9.tar.gz
gunzip libsamplerate-0.1.9.tar.gz 
tar -xf libsamplerate-0.1.9.tar 
cd libsamplerate-0.1.9/
wget http://fftw.org/fftw-3.3.6-pl2.tar.gz
gunzip fftw-3.3.6-pl2.tar.gz 
tar -xf fftw-3.3.6-pl2.tar 
cd fftw-3.3.6-pl2/
./bootstrap.sh 
make
sudo make install
cd ..
./configure 
make
sudo make install
cd ..
./configure 
sudo apt-get install vamp-plugin-sdk
wget http://www.ladspa.org/ladspa_sdk/ladspa.h.txt
mv ladspa.h.txt ladspa.h
make
sudo make install
cd ..
./configure
make
sudo make install
git clone https://github.com/moddevices/sooperlooper-lv2-plugin.git
cd sooperlooper-lv2-plugin/sooperlooper/
make
sudo make install
cp -r /usr/local/lib/lv2/sooperlooper.lv2/ /usr/local/modep/.lv2/

Again, this might not work directly. Might end up starting again from scratch and trying things more methodically. But it’s so nice that it worked!


#14

Very cool. I didn’t know that there was already a scooperlooper moddevices port. Works great.
I only had to use the these commands.

git clone https://github.com/moddevices/sooperlooper-lv2-plugin.git
cd sooperlooper-lv2-plugin/sooperlooper/
make
sudo make install


#15

Yep! Found out afterwards that it worked directly.

This did help me build a bunch of other effects.