MODEP and Raspbery Pi 4

This Real-Time Kernel works perfectly for me with Buster https://www.raspberrypi.org/forums/viewtopic.php?t=250927

Maybe someone can adapt the build-scripts?

It works well on RPi4 itself, but not on RPi 3 or 2.

Are there any problems providing 2 images?

I’d be happy with a 32-bit 2/3 image and a 32/64-bit RPi4 image. Trying to modify the build scripts now, but still failing a little.

Yes.

Maybe just temporarily.

There are many RPi4 owners now.

1 Like

Any update on this?

My guess is that they’re 100% busy with the launch of Midi-Hub and MODEP is on a backburner now. I’m quite ok with it, as I also want them to really hit the Midi-Hub out of the ballpark, but I sure would appreciate some official word on this, as they kinda promised a new fixed image ages ago in one thread. :wink:

Yeah. I bought a Pi 4 in August just for modep because of the promise “Currently Raspberry Pi 4 is not supported. New release is coming soon!” But theirs and mine interpretation of “soon!” differs some. My Pi 3 went dead while running modep.

The Raspberry Pi 4 OS and the real time kernel were not yet stable enough when we took a stab at building the new OS images. We wouldn’t want a new image to be a downgrade from the previous version. Only just recently the real time kernel became able to boot successfully on all target Pi versions, but we do have a lot of critical work planned already (and the Pi 4 as for everyone else was released as a big surprise), so fitting in around a month worth of OS work we’d like to do is not possible. Keeping this in mind, we’re looking for someone to help us out with building the new versions of the OS images.

If anyone would like to take this on themselves, you may find existing MODEP generator scripts here: https://github.com/BlokasLabs/modep

1 Like

Thanks for the update! :ok_hand:

For those that want to play with the Mod stuff on Raspberry Pi 4, it isn’t very difficult to get working.

On a Pi 4 running Raspbian, I cloned mod-host and mod-ui from the mod github repository, built and installed them, and it just worked with the lv2 plugins I had installed from guitarix.

1 Like

Would you mind posting a very short walk through of the process, please?

Thank you very much in advance.

1 Like

Sure - I’ll try to write something up.

1 Like

Hi,
with the newest Patchbox image and a new RPI4 I do not get any USB port, mouse & keyboard to work.

If I do “sudo rpi-update” the USB ports and USB devices are working fine with the updated kernel 5.4.51-v7l+.

I’ll get the Pisound in a few days and because the setup via ssh is working I’m looking foreward to use everything as intended but of course working USB ports are desired.

I had no success to use a different compiled kernel - via this description:

I had succes to compile and boot this kernel but I assume the kernel has to be compiled in regard to MODEP?

Is it possible to use a different kernel with Patchbox/Pisound and if so how to do it?
@Giedrius these MODEP generator scripts you are writing about here:

is there more information about the usage and/or the kernel build process in general?

Could using this rt patched kernel 5.6 work? :


https://mirrors.edge.kernel.org/pub/linux/kernel/projects/rt/5.6/patch-5.6.19-rt11.patch.gz
https://aur.archlinux.org/cgit/aur.git/tree/parameters.patch?h=snd-usb-audio-lowlatency-dkms

links found here:

https://www.raspberrypi.org/forums/viewtopic.php?t=250927

cheers

Hi, the Linux kernel developers are doing their best to keep the user space software forward and backwards compatible in regards to kernel versions, and they seem to be succeeding quite well. So as long as the kernel you’re using supports the Raspberry Pi hardware version you want to use, it should be good to go.

Some useful links for kernel building, as well as how the last Patchbox OS kernel was built:

@Giedrius thank you very much!
I’ve patched and compiled the kernel 5.6, copied it to a fresh Patchbox sd card,
as described at the page you have linked above, and it works!
I cannot say anything about stability because it’s as fresh as my pisound (arrived today).
So far - I’ll attach the pisound tomorrow.
cheers

1 Like

Please let us know how it goes! I assume you’re using RPi4 8GB?

Yes, I’m using a RPI4 8GB.
After flashing Patchbox I did
apt-get updtae && apt get -y dist-upgrade
and
rpi-update
to get Patchbox running a kernel version 5 and newest firmware already
before manually updating to the patched kernel 5.6.
I did this because the first time I tried to manually updating to 5.6
I did it with a current not "rpi-update"ed Patchbox image with kernel 4 and it failed to boot.
After the “rpi-update” the USB ports were starting to work
and after manually copying the patched 5.6 kernel they are still working.

The pisound is running but the HDMI output stopped working with connection the pisound.

Do you mean video or audio output over HDMI?