Getting Sound through amplifier


#1

I have setup the PiSound board on a Raspberry Pi3. I used the black spacers and screws to secure it. I did notice that when I used the spacers, vs No spacers, the 2 boards were not fully touching though GPIO. In other words, with the black spacers, I was only able to push the PiSound board 90% of the way, onto the Raspberry Pi3; still majority on the GPIO pins, but not fully.

Additionally I set it up (installs for puresound, etc) using SSH through ‘pi@IP Address’. I don’t know if that makes a difference.? Because I noticed someone mention that there are sample pd files in ‘/usr/local/puredata-patches’. Additionally, there was mention of putting a .pd file on a USB stick and then inserting the stick into the Pi3. However, how does PiSound know where to read the ‘main.pd’ file from? I changed my USB directory to ‘/home/pi/usbdrv’ from ‘dev/sda1’ ; does this matter? Is there code or conf that I can change to tell PiSound to read from ‘main.pd’.

Also, what is the method for having multiple subdirectories in this ‘mapped’ directory (like ‘.fuzz’, ‘/tremolo’) which all contain a ‘main.pd’ that can be toggled through the ‘Button’?

Right now I have plugged my Guitar 1/4 in the the ‘in’ jack, and sent the 1/4 Jack from ‘out’ into my Guitar Amplifier. I click the ‘Button’ but I get no signal or noise out of my amp. Just red LED light-ups on the actual PiSound board.

I was able to run ‘speaker-test -Dsysdefault -c2’ (although I can’t interpet the output, no noise came from my amp), AND the 3 tests ‘amidi -L, arecord -L, aplay -L’ (it appears that the piSound is the sound driver).

Any ideas where I missed?
Thanks


#2

Hi bears34egc,

This is by design (there is no header part with longer pins available) - just make sure that the Pisound board appears to be straight, if not, just squeeze the boards together on the headers side a bit.

On stock Raspbian, attached USB drives appear in /media folder on the system. The very first main.pd found is the one that will get launched. In case no main.pd was found in the attached USB drives, it will then search for the first one in /usr/local/puredata-patches.

You may change the search locations by modifying /usr/local/pisound/scripts/pisound-btn/start_puredata.sh.

The first main.pd found is the one launched. To switch between different patches it’s best to have multiple USB sticks, one for each patch you want to use.

We’ll be releasing Pisound app for Android soon that will allow browsing your patches on your phone and launching the selected one.

You’d have to have a patch which would pass through the guitar sound. We’d recommend using MODEP with such a setup, download and flash the image from https://blokas.io/pisound/docs/MODEP/#setup-instructions. Don’t do manual install, as it’s only compatible with Jessie versions of Raspbian, we’ll update the image once we’re finished porting more plugins to it.

Try plugging in headphones and see if there is sound. If there is still no sound, power off, unmount the board and mount it again, squeezing the boards together a bit on the header side, and try again. Another common issue is an unsuitable power supply - you should use one capable of 5V or 5.1V, with 2A or more current supply.


#3

Ok THank you. I followed these instructions and did a manual install to an existing Raspian.
https://blokas.io/pisound/docs/MODEP/

When I open MOD Emulator for PiSOund and ‘Check System Status’, I see the following:

–jack.servise active
–mod-host.servise activating
–mod-monitor.servise active
–mod-ui.servise inactive
–pisound-btn.servise active
–pisound-hotspot.servise active
–touchosc2midi.servise failed

When I try tp go to my local IP address or the mentioned 172.24.1.1 in a Browser window, after logging in via SSH using pi@ with password , I am successful logging but nothing comes up in the browser window. Do I need to port forward if I am SSH’ing into the RaspPi via another laptop, ie, “ssh -L 8888:127.0.0.1:8888 pi@”


#4

Sorry, I meant to explain that the manual setup is currently broken on latest Raspbian versions - we are going to deprecate the manual setup completely after the next MODEP update. For now you should flash the OS image from http://www.mediafire.com/file/oya6bq5sct658ba/modep.zip

172.24.1.1 IP would work only if you have connected to the ‘pisound’ wifi network. If you’re on the same network otherwise, you should use the same IP as you used before.


#5

Ok. Thanks again. I used sketcher to write it to a MicroSD. I launched the Pi3. Then I tried connecting to ‘pisound’ SSID via Android phone, Android Tablet, and Windows tablet
The only success I had was once with the Windows laptop. I briefly was able to see the Interface on 172.24.1.1 (pedals, etc.). However, it disconnected on me. And I have not been able to reconnect on any device, and thus through the Browser on 172.24.1.1.
Is this possibly power related? I have a 5V 2.1A Power Supply I bought from Adafruit (or possible other reputable source). I’m perplexed? Do I need adjust the pisound Network, from WPA, or other?
Thanks


#6

Ok., Perhaps I had to be plugged into the 1/4 Jacks. Once I did that, I had no trouble accessing the interface through the SSID.
Now I just need to get familiar with the effects and uses of MODEP. It seems in-depth, if you know any good resources?
Thanks


#7

Hey, you should experiment with the plugins available and see what effect they have. See https://blokas.io/pisound/docs/MODEP/ for a quick description on how to use the button to switch to different pedalboards on the first bank (see screenshot). Basically you can create a set of pedalboards for playing live and switch to desired one by quickly clicking the button a particular number of times.


#8

Ok. Thanks. you’ve been really helpful. But I have kinda done that now. And understand about setting up signal chains and linking to the’Button’, mostly.

But I’m more interested in the actual effects. I tried linking up through the DAW some effects (like Organ or synth) etc, and they won’t connect. I don’t think it’s a user error. Are there some that won’t work along a certain signal chain, or my actual instrument? It looks like these were actually sourced from somewhere else to create MODEP? I’m assuming somewhere then, these effects were created and there’s even a little more than just the '!" description offered on the DAW?
Thanks


#9

Such ‘sound generators’ expect MIDI as the input - unfortunately the sockets are not clearly distinguished in MOD UI. Connect some MIDI gear and click the MIDI ports button near the bottom right to open a menu allowing you to enable some MIDI Input devices, they will appear on the left of the screen, along side the Audio Input jacks. Those are then connectable to sound generators.

Correct, the vast majority of plugins exist in other UI formats as well. They all follow ‘LV2’ plugin standards, and the ones available in MODEP implement ‘modgui’ lv2 extension.

To find the source code of the plugins you’re interested in finding about more, find their *.mk file in https://github.com/moddevices/mod-plugin-builder/tree/master/plugins/package/ - such files will have a reference to where its source code is located, and from there you may be able to find more documentation on them or their websites if any.

Let’s take Calf plugins as an example: https://github.com/moddevices/mod-plugin-builder/blob/master/plugins/package/calf/calf.mk#L7

CALF_VERSION = 0.0.60
CALF_SITE = http://calf-studio-gear.org/files/
CALF_SOURCE = calf-$(CALF_VERSION).tar.gz

From this, we can see its homepage being http://calf-studio-gear.org, but we can also build a link to its source code: http://calf-studio-gear.org/files/0.0.60.tar.gz

Similarly you may find info on the rest of the plugins.


#10

“Connect some MIDI gear” . I don’t have any Midi gear. Just 1/4 Jack for guitar to amp. Could I use a female 1/4 Jack with MiDi adapter to connect my guitar signal into MIDI input Jack. And then 1/4 output to amp, and then use those effects?


#11

That wouldn’t work - MIDI devices produce digital data about notes being played as well as values of the knobs when they’re changing and tempo information for syncing devices, so analog signals produced by guitars are incompatible.

You should look for some MIDI keyboard to use with those plugins.


#12

I see more plugins here …https://github.com/moddevices/mod-plugin-builder/tree/master/plugins/package/gxtonemachine
than the actual UI that I am using. Is it possible to add more through the Pi via a Git pull to that above site? Or some other method to add more effects.


#13

Yes, it’s possible. Which UI are you using?

Usually on Linux you have to build the package from its source code and install it. If you are lucky, someone has made a .deb package which may be installed using apt-get.

Try following the steps for building here:

It also tells you what the dependencies of these plugins are, so try doing this before building:

sudo apt-get install libc6-dev libgtk2.0-dev libstdc++6-dev lv2-dev

After ‘sudo make install’ step, the new plugins should become available in the lv2 compatible software, usually after restarting them.


#14

Yes I was thinking along the lines of this…
“”“For releases 1.5.0 and later, there is an option on the special settings page: http://modduo.local/settings (or http://192.168.51.1/settings if you don’t have zeroconf working).”""

I’m using MODEP. Since it’s not actually on my Wifi Network, I’m assuming the best way to go is to Log into the machine directly and try to install. I’ll try that…


#15

Ah, I thought you intended to use some other DAW with the plugins.

I am working on updating MODEP to contain all of the plugins with MOD gui available (not all of them have it in mod plugin builder repository)

Some instructions on how to get more plugins into the current MODEP image were posted by @Enkerli here: Many More Extra MODEP Plugins