CC LFO mode option not present in UI, only 'retrigger'

First time really using the MIDIHub editor so hopefully this isn’t expected behaviour!

I’d like to set a CC LFO to run a slow sine wave constantly on MIDI channel 4, on CC 1. However in the editor when I place a CC LFO as a generator the only option available is ‘retrigger’ and there is no ‘mode’ option as per the manual. I’d like to select ‘free running’ so it runs constantly but no drop-down appears. I’ve attached a screenshot (I’m limited to only one, so I attached the properties inspector)

Mac OS 10.15.4 running firmware and editor version 1.11.1.

Any ideas?


1 Like

Hey, the ‘mode’ parameter only applies when it’s placed as a ‘modifier’ and has the gray background. If it’s placed as a genarator, it’s ‘free running’ by default.

Ah ok, thanks for clarifying. Something to add to the docs?

1 Like

Thank you for the suggestion, it definitely makes sense to explain this better in the docs. :slight_smile:

1 Like