Best way to remove static?

#1

I am getting a lot of static noise from pisound when it’s running, and I can hear pitch changes in the noise as LEDs blink. What is the best way to reduce/remove this noise?

I am using pisound with a raspberry pi 3b+ and modep.

For power, I am using a 12v to micro usb regulator that plugs into my isolated pedal board power supply. (https://www.amazon.com/gp/product/B00U2DGJD2/ref=ppx_yo_dt_b_asin_title_o00_s00?ie=UTF8&psc=1)

Thanks,
Vitaly

0 Likes

#2

Hi, could you try a regular 5.1V, >=2.5A power supply that plugs directly to an electrical socket? Usually the noise gets caused by a noisy power supply.

We recommend this supply: https://www.raspberrypi.org/products/raspberry-pi-universal-power-supply/

0 Likes

#3

Got a truly isolated power supply, and this fixed my problem.

3 Likes

#4

Hello Vitaly, sorry to bump up this conversation, but I’m experiencing background noises too and I’d like to know the model of power supply you used, as I’m about to build a live performance pedalboard.

0 Likes

#5

There are many types of noise that can be experienced, and they usually have separate potential sources, so it’s probably best to qualify the type of noise first.

Noise could be analog or digital, and could originate from the power supply (eg 60/50Hz hum, or ripple), the Raspberry Pi, the sound card, or even the software - I’ve found many of the LV2 plugins to be great little noise generators.

The original poster mentioned “static”. To me, that implies a high pitched noise, and he said “pitch changes in the noise as LED’s blink”. I’m quite familiar with that sound, which I can reliably evoke by changing pedalboards from the Mod UI. I’ve identified it as digital noise from the Raspberry Pi. The transistors within are changing state thousands or millions of times per second. That creates EMI which gets inductively coupled into the signal lines of the audio card. Also, the Wi-fi module is sending/receiving data to/from my computer and I believe that can induce noise as well.

Three things helped my noise problem:

  1. Housed my system in an aluminum enclosure grounded to the input/output jacks. Shunting whatever EMI to ground is the best solution I’ve found so far.

  2. Physically separated the sound card from the Raspberry Pi. Yup, not the sexiest or practical of solutions, but it made a modest difference. I also tried placing a grounded copper sheet between the two. That actually didn’t make a noticeable difference.

  3. Disabled WiFi (and/or bluetooth):
    https://raspberrypi.stackexchange.com/questions/53149/disable-power-on-wifi-and-bluetooth-interfaces-during-boot

If you do that, you’ll want to make certain that you’ll still be able to connect via a wired ethernet connection, and be able re-enable wireless communications by removing those configuration lines.

As a less drastic measure you could also try triple clicking “The Button” to toggle the wifi hotspot to see if that makes a difference.

0 Likes

#6

I am using https://www.amazon.com/gp/product/B07BWBBZ1C/ref=ppx_yo_dt_b_search_asin_title?ie=UTF8&psc=1

0 Likes

#7

Ah! I hadn’t noticed that your power supply was 12v and then you reduced it to 5v. That could be your problem. Hard to know if that voltage converter is a linear regulator or a switch mode buck converter. Given it’s size, it’s likely the latter which is apt to induce high freq switching noise. If it’s a linear regulator, it likely doesn’t include a large enough filter capacitor to smooth out the ripple. Either way, it wasn’t meant for high def audio, likely more for charging.

So, you really should try a power supply that starts at 5V instead of converting it to 5V and see if the noise persists.

0 Likes

#8

Thank you all for the replies. I eventually decided to buy the supply that Giedrius suggested and it helped a lot… Not dead quiet but, it’s usable! :slight_smile:

0 Likes