ALO looper plugin build

I currently have Sooper Looper on a pedalboard but I’m not a huge fan as it doesn’t really give me what I’d like. After a Google around I came across the ALO plugin (https://github.com/devcurmudgeon/alo) which is now part of the https://github.com/moddevices/mod-plugin-builder and I’d really like to give it a try as an alternative looper but I don’t know how to go about building it for the PI and getting it integrated into MODEP.

I’ve tried to look at the mod-plugin-builder docker (details from Many More Extra MODEP Plugins) but didn’t get very far as I struggled to get git working to update the submodules - kept on failing on network connections even though I’m using ethernet (not wifi).

Is there a simple way to get the plugin build for MODEP - it uses a .mk build file.

Thanks

Greg

2 Likes

Here’s how to build it, and fix one crash that happens when placing it in the pedalboard:

Install prerequisite library, get the source:

sudo apt install liblilv-dev
git clone https://github.com/devcurmudgeon/alo
cd alo/source

Then edit the alo.c:

nano alo.c

Change this line:

if (self->loop_index % (self->loop_samples / self->loop_beats) == 0) {

so it looks like this:

if (self->loop_beats != 0 && self->loop_index % (self->loop_samples / self->loop_beats) == 0) {

This avoids a division by zero crash, as loop_beats is still 0 at the beginning.

Hit Ctrl+X, then Y to exit and confirm saving changes.

Then build and install:

make
sudo cp -r alo.lv2 /usr/modep/lv2/

Restart MODEP so it sees the new plugin:

sudo systemctl stop jack
sudo systemctl start modep-mod-ui
1 Like

@Giedrius Finally had chance to try your solution and it’s built and installed and appears in the MODEP UI. Thanks.

Unfortunately, when the plugin is not in ‘bypass’ mode, no audio comes through or triggers starting the loop. Is there a way to debug/view logs to try and see why there is no output when the pedal is enabled.

Thanks for your help with this.

Set LOG_ENABLED = true here: https://github.com/devcurmudgeon/alo/blob/master/source/alo.c#L86

Edit log file path here: https://github.com/devcurmudgeon/alo/blob/master/source/alo.c#L95, set it to /tmp/alo.log, as MODEP runs as modep user, and does not have access to /root.

Build it again and reinstall, you’ll find the log in /tmp after using it in MODEP. :slight_smile:

1 Like

@Giedrius Thanks. Was able to do a bit of debugging but in the end it my main problem was that the clock wasn’t triggering the pedal so never started. Once I’d figured that out, loop recording started. It still doesn’t play sounds through the pedal - only on playback of the loop so I just feed my instruments to both the ALO looper and the output.

Still need to play around a bit with it but seems to be working now. Thanks for your help.

1 Like